Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Why are my animations laggy and slow on my laptop? AMD Turion tl-56 and HD 3200 with 2 Gig Ram.

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

Too much useless animation and effects activated in Unity... Unity3D makes the system extremely slow but only low Graphic Card and/or can actually reproduce the lag and slow animations.

I am in the same case as you because I use an Asus 1215N with a Dual Core ATOM processor and an Intel Graphic card since the Optimus doesn't work natively...

But you can still do some configurations to help a little bit with the problem like this :

When using Unity-3D:

  • Use the proprietary ATI drivers available in Ubuntu.

  • After installing ccsm (Compiz Config Settings Manager) :

    • Disable Sync to VBlank (as mentioned by @duffydack)
    • In Composite Plugin > Select your Refresh Rate (available at Screen Settings) and then uncheck "Detect Refresh Rate".
    • In OpenGL > "Texture Filter" select "Fast" instead of "Good", and choose "Texture Compression" (this feature will use a little bite more of the process but will help with graphics so it is at your choose (you can have the 2 options unselected though)

And I think it is all you can do (for me even Unity-2D is slow so I think it is the fault of my processor... even if this problem of slowlyness doesn't occur neither in Gnome-Shell or Windows (but the last one is probably due to the fact that the Nvidia Optimus works and on Linux it doesn't....)

Hope this helps.

share|improve this answer
    
Thanks you for your help –  rockr101 Oct 18 '11 at 2:04
    
I forget to mentioned the Unity settings in Compiz, you can change the blur to No Blur which will make the Launcher/Lens work better and launch faster. –  aliasbody Oct 18 '11 at 10:41
add comment

use compizconfig-settings-manager to disable vsync
from a terminal type sudo apt-get install compizconfig-settings-manager
click the dash, type ccsm, click and run, and in the OpenGL plugin disable Sync to VBlank

share|improve this answer
    
Did that, still lags. But thanks anyway. –  rockr101 Oct 18 '11 at 2:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.