Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How do I add a kernel boot parameter?

I just upgraded to 11.10 from 11.04 on my laptop (I don't have Windows) by downloading from the Ubuntu website. The laptop battery is in bad condition, but I was using it with the 11.04 plugged to AC all the time, and everything was fine.

After installing 11.10, the laptop seems to not notice that it is connected to AC, so it shuts down a few minutes after starting. I read that I have to type pcie_aspm=force in the boot command, so I tried accessing it by pressing the "F6" key while booting, and then the other F keys, but nothing happened. I also found that I can write that instruction in the terminal window, but I don't know in which file or location. I would appreciate some help, but I am not a computer engineer, so please write the instructions in plain English.

share|improve this question

marked as duplicate by Marco Ceppi Nov 29 '11 at 11:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

3 Answers 3

To apply it to all kernels, edit /etc/default/grub (root privileges required) and change:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force"

Run sudo update-grub afterwards.

To edit the boot options on startup, hold Esc while starting GRUB (after the BIOS POST). Press E on the selected entry, use your arrows to move and keyboard to type. When done, press Ctrl + X to boot.

share|improve this answer
    
Thanks Lekensteyn. I edited the _DEFAULT line as you wrote, but I didn't find how to run the "sudo update-grub". However, I could save the edited file by pressing CTRL O (like "Oscar") which I found in the Help of the Terminal as the command to save changed files. But it didn't work, the laptop continues not noticing that it is connected to the wall outlet. Seems like there is a setting telling it to run from the battery only (cable was OK 5 days ago). But I didn't try to put the "pcie_aspm..." before the "quiet splash". Please help, it only runs for 5 minutes. –  nargo7 Oct 18 '11 at 10:13
add comment

In the linked question below, the OP asked a similar question - in their case they wanted to add nomodeset to GRUB.

You could use the same advice given but substitute nomodeset for *pcie_aspm=force*


Linked Question:

  1. How to set nomodeset for installation?
share|improve this answer
    
Thanks fossfreedom. I edited the _DEFAULT line as you wrote, but I didn't find how to run the "sudo update-grub". However, I could save the edited file by pressing CTRL O (like "Oscar") which I found in the Help of the Terminal as the command to save changed files. But it didn't work, the laptop continues not noticing that it is connected to the wall outlet. Seems like there is a setting telling it to run from the battery only (cable was OK 5 days ago). But I didn't try to put the "pcie_aspm..." before the "quiet splash". Please help, it only runs for 5 minutes. –  nargo7 Oct 18 '11 at 10:13
    
I doubt that pcie_aspm will work. I would use a boot option such as "acpi=off" to turn off power management. Run sudo update-grub in a terminal. –  fossfreedom Oct 18 '11 at 10:15
add comment

One-line solution, use at you own risk:

sudo sed -i 's/GRUB_CMDLINE_LINUX_DEFAULT=\"\(.*\)\"/GRUB_CMDLINE_LINUX_DEFAULT=\"\1 pcie_aspm=force\"/' /etc/default/grub && sudo update-grub
share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.