Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The upgrade went smoothly, Dropbox is working (i.e. it is syncing files), but the icon overlays aren't appearing no matter if I use Unity, Unity 2D or GNOME Shell.

Is there any setting that can fix this?
Is there a new version of the Dropbox extension for Oneiric?

share|improve this question
    
There is a version of nautilus-dropbox for oneiric. Have you tried reinstalling and restarting Nautilus after? –  kikixx Oct 17 '11 at 23:40
    
@kikixx: Yes, I have. Is this version available in default Ubuntu repositories? –  Marek Grzenkowicz Oct 18 '11 at 6:23
    
What version are you on? I'm running nautilus-dropbox 0.6.8-1 from the software centre (no extra sources needed) and it's working perfectly here. –  kikixx Oct 18 '11 at 10:08
    
@kikixx: I'll check in the evening - it is possible that I am running a natty version from Dropbox repositories. –  Marek Grzenkowicz Oct 18 '11 at 10:20
add comment

3 Answers 3

up vote 3 down vote accepted

Found the following post on the dropbox forums, so two things to try (I can confirm it is working on my computer with nautilus-dropbox 0.6.8-1).

1) Downgrade to nautilus-dropbox 0.6.8-1 if running a newer version.
2) Try running the following commands if on the newer version:

    sudo ln -s /usr/lib/nautilus/extensions-2.0/libnautilus-dropbox.a /usr/lib/nautilus/extensions-3.0/libnautilus-dropbox.a  
    sudo ln -s /usr/lib/nautilus/extensions-2.0/libnautilus-dropbox.la /usr/lib/nautilus/extensions-3.0/libnautilus-dropbox.la  
    sudo ln -s /usr/lib/nautilus/extensions-2.0/libnautilus-dropbox.so /usr/lib/nautilus/extensions-3.0/libnautilus-dropbox.so
share|improve this answer
    
I removed the Dropbox repository from the sources list, uninstalled Dropbox (version 0.6.9), installed it (version 0.6.8-1) and now it's working properly. –  Marek Grzenkowicz Oct 18 '11 at 20:39
add comment

According to this blog post, nautilus-dropbox already has GTK+3 support. There is just one missing symlink, which can be created with this command:

cd /usr/lib/nautilus/extensions-3.0
sudo ln -s ../extensions-2.0/libnautilus-dropbox.so .
nautilus -q
share|improve this answer
add comment

Version 0.7.0 seems to solve this problem.

You can get the packages here: http://forums.dropbox.com/topic.php?id=46448

share|improve this answer
    
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  hexafraction Jul 19 '12 at 12:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.