Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

up to Ubuntu 11.04 all my LVM volumes used to show up in the sidebar of Nautilus as devices available to be mounted, alongside software RAID volumes. after upgrading to 11.10 last week, i can only see software RAID volumes (i can mount/umount them) but i can't find a way to make Nautilus show LVM volumes (on both my main desktop systems).

i guess this must be a change in gio/gvfs but i can't find any settings for this - anyone has experienced this issue upon upgrading to Gnome 3.0/3.2 and has figured out how to make LVM volumes appear in Nautilus' sidebar?

i can mount the volumes manually ok from the command line. none of them is in /etc/fstab.

share|improve this question

1 Answer 1

It sounds like your LVM volumes were never configured to mount at boot to begin with, that requires user intervention to modify /etc/fstab. Even if Nautilus were functioning as it was, fstab isn't modified for runtime mounts, /etc/mtab is, which is sometimes a symlinked to /proc/mounts.

In examining gvfs behavior in 11.10 and 12.04, gvfs-mount -li doesn't seem to care at all for any fixed disks, it will list my cd-rw and that's it. This may have always been true, I haven't checked the changelogs.

It may be that this isn't gvfs related at all and volume mounting is enabled by Udisk, which will list every storage device in the system. That would indicate either that the data presented by Udisk has changed slightly which is then masking out your Logical Volumes, or Nautilus has changed the default policy somewhere and hid it in a code change or somewhere in the gconf registry.

Either way I would consider this a regression and worthy of a bug report.

I've always had a problem with storage "desktop volume click-to-mount/hotplug-mount" in Linux, the actual policy gets squirled away in the desktop implementation so every desktop gets to implement their own policy. That policy is never well documented.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.