Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm getting a large number of disconnects from my wireless when I switched to oneiric server (I did not see these happen with oneiric desktop) from my AR9285 wireless LAN device. Here is the syslog snippet:

Oct 17 09:43:17 weather kernel: [ 1537.329138] wlan0: deauthenticated from 00:12:17:7a:8e:42 (Reason: 7)
Oct 17 09:43:17 weather kernel: [ 1537.340409] cfg80211: All devices are disconnected, going to restore regulatory settings
Oct 17 09:43:17 weather kernel: [ 1537.340423] cfg80211: Restoring regulatory settings
Oct 17 09:43:17 weather kernel: [ 1537.340435] cfg80211: Calling CRDA to update world regulatory domain
Oct 17 09:43:17 weather kernel: [ 1537.348571] cfg80211: Ignoring regulatory request Set by core since the driver uses its own custom regulatory domain
Oct 17 09:43:17 weather kernel: [ 1537.348581] cfg80211: World regulatory domain updated:
Oct 17 09:43:17 weather kernel: [ 1537.348586] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Oct 17 09:43:17 weather kernel: [ 1537.348594] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Oct 17 09:43:17 weather kernel: [ 1537.348600] cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Oct 17 09:43:17 weather kernel: [ 1537.348607] cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Oct 17 09:43:17 weather kernel: [ 1537.348613] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Oct 17 09:43:17 weather kernel: [ 1537.348620] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)

Here is the relevant lspci output:

# lspci | grep Atheros
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

I have done quite a bit of searching and saw discussions for previous versions of ubuntu that recommended installing the linux-backports-modules package. However, this does not appear to be available for oneiric (just the headers are listed as a package).

Any advice on how to achieve a stable wireless connection for this server? It's location mitigates against using a wired connection.

share|improve this question
    
If possible post result of dmesg , iw phy phy0 and iw reg get –  BigSack Jun 16 '12 at 15:08

2 Answers 2

Try the following workaround, that seems to work for many people:

sudo su -c 'echo options ath9k nohwcrypt=1 > /etc/modprobe.d/ath9k.conf'

Then just reboot. Hope that helps!

share|improve this answer

I've been searching this one. If the first answer given by artfwo doesn't work try this one : http://askubuntu.com/a/55004/31838

This answer over there worked in my case (same wifi chip on Ubuntu 11.10 oneiric 64bit)

Oh! And I had to put down IPv6. IPv6 seemed to crash my connection a bit.

Hope this helps you

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.