Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Ubuntu and intended to use my 1920x1080 monitor with my 1440 x 900 laptop via HDMI, however, when I went into system settings to extend the displays I got this error:

The selected configuration for displays could not be applied requested position/size for CRTC 147 is outside the allowed limit: position=(1920, 180), size=(1440, 900), maximum=(1920, 1920)

I tried installing the proprietary drivers for my graphics card, which is an ATI Mobility Radeon HD 3650 and then changing my settings through the ATI Catalyst Control Center as one of the solutions online suggested, but this did not work.

The strange thing is the 1920x1080 screen seems to display 2 bars accross the top with 2 sets of wifi status icons, battery/email etc.

Any help would be greatly appreciated as I love the way ubuntu looks and can't wait to begin learning more about this OS.

share|improve this question
    
Great! Welcome to Ubuntu. Your first lesson is that Ubuntu is undergoing massive changes just now, and particularly with regards to multiple monitors, there are numerous issues to fix. Bugs are reported on launchpad.net. What you're experiencing is no doubt a bug, and it would be nice if you took the time to report it. If you need help doing that, please open a new question about it. :) –  Jo-Erlend Schinstad Oct 17 '11 at 16:03
    
Thanks for the quick answer, I definitely will report this bug, but I forgot to mention in my original post that initially it worked fine, it was only after i installed ATI's proprietary drivers it messed up and now it won't revert to how it was before no matter what I do. –  Carwyn Stephen Oct 17 '11 at 16:09
    
In the meantime, until it gets fixed, you can probably log in using Unity 2D. You choose it by clicking the button next to the password field when you login. –  Jo-Erlend Schinstad Oct 17 '11 at 16:27
add comment

4 Answers 4

up vote 2 down vote accepted

Try moving /etc/X11/xorg.conf somewhere else, like /etc/X11/xorg.conf.disabled, then rebooting (or just restarting the display with sudo service lightdm restart or sudo service gdm restart). This worked for me. I'm using Unity 2D, by the way.

I also tried the proprietary driver(s), then going back to the FLOSS drivers, neither of which seemed to help. I think I'm back to using the FLOSS driver(s) now.

share|improve this answer
    
Thanks for that, it worked :) –  Carwyn Stephen Dec 12 '11 at 19:27
add comment

I had the same issue and found this solution elsewhere:

Edit your /etc/X11/xorg.conf

Section "Screen"
  Identifier "Default Screen"
  Device "Default Video Device"
  DefaultDepth  24
  SubSection "Display"
    Virtual 3840 1080
  EndSubSection
EndSection

The above sample is what I am currently using for the Section block - you will need to edit the Virtual parameter to describe your multi-monitor resolution; in my case it is dual 1920*1080p.

Once you have done this you need to log out (or reboot), then go back into the Catalyst Control Centre (Administration mode) and configure your Multiple Displays.

share|improve this answer
    
I had the same issue as the OP, and I solved it using this method -- almost. I added the Virtual block like you did, using the larger of the vertical and horizontal sizes for the virtual display size. Then I added multi display in the Catalyst Control Center (from the terminal run gksudo amdcccle). Reboot. Open the ubuntu display manager ("Displays" in the system settings) and set up multi display. –  Olhovsky Nov 3 '11 at 5:13
    
Thank you, this seamlessly worked for me. –  gmile Dec 17 '11 at 10:49
    
This solution works with the open source radeon driver, which is what I needed. There are numerous places that recommend installing the proprietary fglrx driver, which may be the best solution for many people. But I have been unable to get the proprietary driver to work witn Xen--so this is the solution I needed. –  Dan Menes Mar 22 '12 at 20:13
add comment

Try to run sudo aticonfig --initial and then reboot

share|improve this answer
add comment

Just managed to get dual monitors working flawlessly with my Toshiba L645 (two monitors, external running at 1920x1080 and laptop monitor at 1366x768). Just need to change the xorg.conf and change Settings - Displays.

**Section "Module"
    Load "GLcore"
    Load "dbe"
    Load "dri"
    Load "extmod"
    Load "glx"
    Load "freetype"
EndSection

Section "Device"
    Identifier "Mobility Radeon HD 4500/5100 Series"
    Driver "fglrx"
EndSection

Section "Monitor"
    Identifier "ViewSonic 1080p"
    VendorName "ViewSonic"
    ModelName "1080p HD"
    HorizSync 31.5-48.5
    VertRefresh 40-70
    Modeline    "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
    Option          "PreferredMode" "1920x1080_60.00"
    Option      "DPMS"
EndSection

Section "Monitor"
    Identifier "Laptop Monitor"
    Option      "DPMS"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device "Mobility Radeon HD 4500/5100 Series"
    Monitor "ViewSonic 1080p"
    DefaultDepth 24
        Subsection "Display"
        Depth 24
        Modes "1920x1080_60.00"
        Virtual 3286 1920
        EndSubSection
EndSection

Section "Screen"
    Identifier "Screen1"
    Device "Mobility Radeon HD 4500/5100 Series"
    Monitor "Laptop Monitor"
    DefaultDepth 24
        Subsection "Display"
        Depth 24
        Modes "1366x768"
        **ViewPort 1920 0 # This is important!!!** 
        EndSubSection
EndSection

Section "ServerLayout"
    Screen "Screen0"
    Identifier "External"
EndSection

Section "ServerLayout"
    Screen "Screen1"
    Identifier "Laptop"
EndSection

Section "DRI"
     Mode 0666
EndSection**
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.