Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've Ubuntu 11.10 and my problem is about the touchpad. At the beginning of my computer it's works fine, but after opening an application or a few minutes, it stops working and I have to use a USB mouse. Someone could help me? Thank you very much:)

share|improve this question
    
I am experiencing the exact same behaviour... but uncheck of 'disable touchpad when typing' option didn't help at all. I have ps/2 touch pad before log in (can mouse to password field on gdm). When I log in, mouse immediately stops working. rmmod / modprobe doesnt' seem to help. –  user31489 Oct 31 '11 at 2:12
add comment

5 Answers

up vote 3 down vote accepted

I had the same problem as well, the only thing that I did was in the terminal:

    unity --replace

after that it hasn't been an issue.

share|improve this answer
    
Perfect... also replacing the synaptic drivers! :D ;) Thanks –  Manuel Andrés Vélez Oct 18 '11 at 0:37
    
@ManuelAndrésVélez I also have the same problem. Can you tell me how you replaced the synaptic driver? –  KasunBG Dec 21 '11 at 6:29
2  
This is total overkill -- replace the entire desktop just for one driver? –  Ryan Reich Apr 29 '12 at 21:16
    
I'm on 12.04, and this doesn't do anything for me. –  Cerin Dec 31 '13 at 3:07
add comment

These solutions didn't work for me (running ubuntu 12.10). The thing that did the trick is:

gsettings set org.gnome.settings-daemon.peripherals.touchpad touchpad-enabled true

Good luck!

share|improve this answer
add comment

If this happents, use Ctrl+Alt+T to open a terminal and type:

synclient TouchpadOff=0
share|improve this answer
1  
This is the best answer. I used to use the modprobe method, but in 12.04, it causes unity or even X to crash. This one does not even need to be root! –  Ryan Reich Apr 29 '12 at 21:16
add comment

I was sucessful with the wollowing treatment: I plugged in a USB mouse Navigate to the touchpad and mouse settings (top right button -> system settings -> Mouse and Touchpad) I then unchecked the disable mouse when typing option. Reboot.

Worked fine using this since! Perhaps there is some weird mouse locking issue related to this setting?

share|improve this answer
add comment

There is another command that works, and is perhaps more direct:

sudo modprobe -r psmouse && sudo modprobe psmouse

The problem is that it is not a permanent solution. I already tried adding psmouse to the /etc/modules file, but the problem is not about the driver not loading, but crashing or something.

Does the unity replacement command work as a "permanent solution"?

share|improve this answer
    
are you talking about unity --replace for me it did. –  st2011 Oct 23 '11 at 0:46
    
This worked for me! –  KasunBG Dec 21 '11 at 6:45
add comment

protected by Community Mar 1 '12 at 13:09

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.