Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Enabling Bias alt-tab sorting to prefer windows on the current viewport as described here made no difference. How can I get back the exact same behavior as 11.04, so that alt-tab only switches between windows on the current workspace?

Simply disabling the alt-tab and shift-alt-tab keybindings on the unity switcher seems to have helped, but it still switches workspaces on me sometimes. For example, if I give a terminal window focus then press alt-tab, it switches to another terminal window on any workspace before trying to switch on the same workspace. Also, the Unity switcher still shows up when I alt-tab then hold alt even though I removed its alt-tab keybinding.

share|improve this question
1  
You'll be glad to hear that this, and these types of issues will be in focus for 12.04. Mark Shuttleworth posted an email about it a few hours ago, regarding exactly this case. Should see great improvements. :) –  Jo-Erlend Schinstad Oct 20 '11 at 21:34
    
I hope someone come out with a simple check-box in in appearearence, behaviour, setting, or at least some plugin like this: extensions.gnome.org/extension/15/alternatetab Any idea where I should file this feature request??? –  opensas May 25 '13 at 1:18

4 Answers 4

up vote 92 down vote accepted

You can revert back to the older style of window switcher by enabling the Static Application Switcher plugin in CompizConfig Settings Manager:

Steps:

  1. CompizConfig Manager is gotten through sudo apt-get install compizconfig-settings-manager (thanks to @donbright)

  2. sudo apt-get install compiz-plugins to get the static application switcher to show up. (thanks to @Milimetric)

  3. CompizConfig Manager is started by typing ccsm in terminal (thanks to @donbright)

  4. Disable the keyboard shortcuts for Unity's switcher by unchecking CompizConfig Settings Manager ▸ Desktop ▸ Ubuntu Unity Plugin ▸ Switcher ▸ Key to start the switcher ▸ Enabled and Key to start the switcher in reverse ▸ Enabled

  5. Enable the Static Application Switcher by checking CompizConfig Settings Manager ▸ Window Management ▸ Static Application Switcher ▸ Enable Static Application Switcher

share|improve this answer
5  
+1: Nice and concise. But there are also warnings about key binding conflicts, and the choices (in Precise) were very confusing. So a bit of advice about that would help. E.g. what is the difference between "set Prev window (All windows) anyway" and "disable Key to start the switcher in reverse for all viewports in the Ubuntu Unity Plugin plugin?" –  nealmcb Apr 30 '12 at 23:58
6  
Really? There's no way at all to disable grouping in Unity's Switcher other than completely disable the switcher itself? –  MestreLion Nov 24 '12 at 10:36
14  
You guys forgot one detail: you have to sudo apt-get install compiz-plugins to get the static application switcher to show up. –  Milimetric May 21 '13 at 14:17
1  
Ping for the question in nealmcb's comment - I'm also puzzled. –  Jonathan Hartley Mar 20 '14 at 16:10
1  
The "Warning" post suggests that the goal as of 12/04 was to reduce the need for CCSM by merging in support for the things folks really want. Given the massive popularity of this (and my continuing state of massive frustration with how the default switcher in trusty works), is any progress being made on at least making a less-scary and better-supported tweak available for switching to the static application switcher? –  nealmcb Jan 13 at 22:02

You should install CompizConfig Settings Manager. From there you can find the Unity plugin

enter image description here

and disable the switcher, by clicking on each of the key bindings and unchecking 'Enabled'

enter image description here

Then you can enable one of the other window-switcher plugins under Window Management.

ccsm

share|improve this answer
    
how do I disable the switcher in that view? Do I just disable or change the key bindings? –  Lilitu88 Oct 18 '11 at 20:01
    
Just disable the keybindings. The shifter is part of the unity plugin, and you probably don't want to disable that plugin :) –  LasseValentini Oct 20 '11 at 12:06
2  
Isn't there a way to disable just the grouping, and not the switcher itself? –  MestreLion Nov 24 '12 at 10:37
2  
In 13.04 I cannot find "Static Application Switcher" in CCSM ;( –  Maciej Łopaciński May 9 '13 at 8:47
2  
@Maciej, you have to install compiz-plugins. See this bug –  ncasas Jun 19 '13 at 18:05

The easy way to do this withing changing the switcher is to check Bias alt-tab to prefer windows on the current viewport. This the second option in the "switcher" tab in the Unity Plugin.

share|improve this answer
    
You may want to edit this answer so users know how to access the Unity Plugin settings (some of the other answers here explain it, but you probably want your answer to be sufficient, even without reference to them). I'd do the edit but there are different ways to explain this and I don't know what you'd prefer. –  Eliah Kagan May 30 '12 at 15:56

Use the Static Application Switcher (configured using CompizConfig/CCSM)

Warning: What are some of the issues with CCSM and why would I want to avoid it?

Save work and close programs before using CompizConfig.

Consider printing out the Display Manager Restart section at the end of this post. Hopefully you won't need it, but if you do, it will be because your screen is temporarily useless.

Install Software

Install Compiz Config (thanks to @donbright):

sudo apt-get install compizconfig-settings-manager

Install the Static Application Switcher (thanks to @Milimetric):

sudo apt-get install compiz-plugins

Configuration

  1. Start CompizConfig Manager by typing ccsm in terminal (thanks to @donbright) or find it in the Dash.

  2. In CompizConfig Settings Manager, navigate to Desktop ▸ Ubuntu Unity Plugin ▸ Switcher Disable ALL the keyboard shortcuts. It should look like this on Ubuntu 15.04 when you're done:

Disable all keyboard shortcuts in the Unity Plugin

  1. Click "Back" to go back to the CompizConfig main page.

  2. Enable the Static Application Switcher by checking Window Management ▸ Static Application Switcher ▸ Enable Static Application Switcher. Things may flicker for a few seconds. If you get warnings, don't ignore them; go back and fix your mistakes. Success looks like this on Ubuntu 15.04:

Enable Static Application Switcher

That's it!

Display Manager Restart (in case of trouble)

Hopefully you won't need this, but it is probably less likely to cause data loss than pulling the power cord. Think of it as rebooting just your display manager instead of the whole system.

# Switch to a terminal session (leaving X-Windows running)
Ctrl-Alt-F1

# (you may have to log in)

# Stop your X-Windows session:
sudo service lightdm stop

# Start a new X-Windows session:
sudo service lightdm start

# Go to the current X-Windows session:
Ctrl-Alt-F7

Thanks!

This started out as @ændrük's answer, but I edited it enough times to make it my own.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.