Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I would like to type Hebrew in Ubuntu. I tried downloading the Hebrew language pack and then setting alt-shift as my layout-change shortcut in the Options section of "Keyboard Layout".

However, when I actually press alt-shift, nothing happens. How can I switch my keyboard layout to Hebrew?

share|improve this question
    
When selecting keyboard key combination to change languages, some combinations do not work (both Alt did not work for me). I am using Shift+Ctrl with no problem. –  user154302 May 1 '13 at 3:07

8 Answers 8

up vote 53 down vote accepted

Ubuntu 13.04 and Older

Seems you forgot an important step.

  1. Download Hebrew language support. You can do this from the Install/Remove Languages section of "Language Support".
  2. System Settings -> Keyboard Layout -> "+" -> "Hebrew" -> Add
  3. System Settings -> Keyboard Layout -> Options -> Keys to Change Layout -> mark [alt]+[shift] (this step is optional, only if you want that custom keyboard shortcut)

An icon like this should appear in the upper-right after step two:

The keyboard indicator


Ubuntu 13.10 and Newer

As of Ubuntu 13.10, it is now called Text Entry Settings instead of Keyboard Layout

It can be reached through either of these methods

  1. Going through System Settings -> Text Entry
  2. Using the App Indicator as shown in the screen-shot below.

App Indicator icon

share|improve this answer
1  
I have the same as above, and still cannot change keyboard layout . . . –  deadalnix Jul 22 '12 at 13:44
    
I have done this, for some reason I have only a close button which is not saving anything. :-\ –  Kahil Aug 10 '13 at 13:37

Double-check if you've got this combination already set in compiz-config. Run it by pressing Alt + F2, then type ccsm, then press Enter. Sometimes, the shortcut is already used by another program, so you can't use it.

Also, please check if it does work using another combination, e.g. CapsLock + Shift.

share|improve this answer

It seems you forgot to add Hebrew keyboard layout. No matter how many possible languages you may have, you have to add all languages you want to WRITE with in your keyboard settings.

Something like: 3.- Settings -> Keyboard Layout -> + -> Hebrew -> Add

share|improve this answer

To switch keyboard layout on Ubuntu 12.04

  1. Go to System Settings...

  2. Under Keyboard Layout - click on Options...

    enter image description here

  3. Under Key(s) to change layout - choose the combination of keys you would like to use.

    enter image description here

share|improve this answer
    
When I set the key combination, and then press it, it doesn't do anything. I can however change the layout by my mouse in the applet, that works perfectly. –  Ondřej Čertík Aug 1 '12 at 17:21

I am a totally new to Ubuntu, I just installed it yesterday and I am loving it, but I have encountered the same problem when I was trying to use keyboard shortcuts to switch from Latin to Arabic, but fortunately I found the solution, here is simply what to do:

System Settings... → Keyboard Layout → (click on "+" to Add new Language layouts) → Options... → (click on) "Key(s) to change layout" → (tick) "Left Alt+Left Shift" → Close

share|improve this answer

If you installed language support after keyboard installed you may be experiencing no action on selected combinations (like @OndrejCertik reported above).

You should reset keyboard layout defaults in that case by System Settings -> Keyboard Layouts -> Reset To Defaults and setup Key(s) to change layout again under Options... there.

share|improve this answer

Settings -> Keyboard Layout -> + -> Arabic -> Add

share|improve this answer

In Ubuntu 12.04 LTS,

Goto the Keyboard Layout Options window I could select Key(s) to change layout and mark the binding of my choice. I use Shift + CapsLock to toggle the layout from the keyboard itself without having to use mouse cursor to select the required layout from the panel indicator. The same key combo seemed to work to serf through or select between multiple layouts. (But in Ubuntu 13.10 it wasn't so easy.) snap5


In Ubuntu 13.10,

Goto the Keyboard settings window, under Shortcuts tab, I select Typing. The default for Switch to next source is Super+SPACE which didn't seem be working for me and so by clicking on it and I assigned a New Accelerator..., to change to next Layout (I used Super+L).

(Then I assigned something similar for Switch to previous source using the same preferred layout, and then began to test them. Switching from the preferred layout to the alternate worked but the reverse did not. Please refer the next step for the fix.) saucy1

The Fix: After assigning Super+L for "Switch to next source" using my preferred layout (A), I changed my keyboard layout to the alternative layout (B) and then assigned the combination to "Switch to previous source" (for which I used Shift+Super+L). Then I tested them, and they work fine. (Maybe disabling "Switch to previous source" would work too.)

The new accelerators for the key combos that I used looks like this: saucy2

I could then switch to layout (A) using Super+L and back to layout (B) using Shift+Super+L.

share|improve this answer

protected by Community May 25 '13 at 8:48

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.