Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Lucid and after installing some upgrades and switching from Gnome to KDE, I found I can no longer connect to the server on my office LAN. I can see it on the network, but clicking on it has no effect. I seem to have the option to connect to it via different protocols - sftp, afp and also Apple Remote Desktop (it's a Mac server i'm trying to connect to), but none of these options work.

Grateful for any pointers on how to sort this!

Running cat /etc/mtab shows:

/dev/sda1 / ext3 rw,relatime,errors=remount-ro 0 0
proc /proc proc rw 0 0
none /sys sysfs rw,noexec,nosuid,nodev 0 0
none /sys/fs/fuse/connections fusectl rw 0 0
none /sys/kernel/debug debugfs rw 0 0
none /sys/kernel/security securityfs rw 0 0
none /dev devtmpfs rw,mode=0755 0 0
none /dev/pts devpts rw,noexec,nosuid,gid=5,mode=0620 0 0
none /dev/shm tmpfs rw,nosuid,nodev 0 0
none /var/run tmpfs rw,nosuid,mode=0755 0 0
none /var/lock tmpfs rw,noexec,nosuid,nodev 0 0
none /lib/init/rw tmpfs rw,nosuid,mode=0755 0 0
/dev/sdb1 /home ext3 rw 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,noexec,nosuid,nodev 0 0
share|improve this question
Could you please describe what you are exactly doing. Currently, I cannot see what the issue has to do with Gnome vs. KDE. – txwikinger Oct 13 '10 at 18:29

Did you try to install afpfs-ng? It's a good solution to access AFP shares on a network. There is a good explanation in this blog post.

share|improve this answer
afpfs-ng is not bundled with gnome or ubuntu. If it worked before it was not through afp. – LasseValentini Nov 8 '10 at 4:12
My answer is more of an alternate solution, than actually solving his problem as I don't know why something would stop working. ;-) – Huygens Nov 8 '10 at 22:33

I think your problem is that samba is not installed by default?


sudo apt-get install samba
share|improve this answer

Gnome, through Nautilus and GVFS can mount network shares on login and this wouldn't be available for KDE to access. KDE, via KIO Slaves, can do this as well, or it can be done through the command line. If Samba was working in Gnome it is probably still there.

In Konqueror type smb:/ or sftp:/ in the location bar to use common protocols for mounting shares, mac servers can do either I believe.

If you needed access w/out KDE or Gnome running you could use fuse-smb for samba or curlftpfs for ftp access, but KDE should be as convenient as Gnome at doing this for you. I use KDEWallet to automount certain network drives.

Samba can be configured through KDE's System Settings -> Sharing. Or possibly System Settings -> Advanced -> Samba.

If you still need help please edit with whether it's a server at work, in a mixed mac/win/*nix environment and whether this is the same install/if Gnome is sill installed.

share|improve this answer

i have also faced similar problem after switching from Gnome to KDE on Ubuntu Lucid. But, I was being unable to login my Win7 pc on company domain.

I got help from

installed smbfs using:

 sudo apt-get install smbfs

also checked the installation of samba itself by trying:

 sudo apt-get install samba

then again, checked with Dolphin, but failed.

then tried with Konquaror, and BINGO. gained access to all my shared folders on the domain.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.