Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

The reason I'm asking is that none of the games I've installed through software center that require 3D accelartion like TORCS for instance will run. When I try to run then, nothing happens. I have a Dell Inspiron N5110 with a nVidia GeForce GT 525M.

I tried the following which I were some suggestions for people with similar problems:

lspci -v

Which gave me:

01:00.0 VGA compatible controller: nVidia Corporation Device 0df5 (rev a1) (prog-if 00 [VGA controller])
    Subsystem: Dell Device 04ca
    Flags: bus master, fast devsel, latency 0, IRQ 16
    Memory at f5000000 (32-bit, non-prefetchable) [size=16M]
    Memory at e0000000 (64-bit, prefetchable) [size=256M]
    Memory at f0000000 (64-bit, prefetchable) [size=32M]
    I/O ports at e000 [size=128]
    Expansion ROM at f6000000 [disabled] [size=512K]
    Capabilities: <access denied>
    Kernel driver in use: nvidia
    Kernel modules: nvidia_current, nvidia_current_updates, nvidia, nouveau, nvidiafb

I also tried:

egrep -i " connected|card detect|primary dev" /var/log/Xorg.0.log

Which gave me:

[    20.873] (II) intel(0): Output LVDS1 connected


nvidia-smi -a

Which gave:

NVIDIA: could not open the device file /dev/nvidiactl (No such file or directory).
Nvidia-smi has failed because it couldn't communicate with NVIDIA driver. Make sure that latest NVIDIA driver is installed and running.

I don't really understand what all this means. Please help.

share|improve this question

3 Answers 3

I know the question is old, but I found a solution which I hasn't find on other topic.

Open a terminal and type

lspci -vnnn | perl -lne 'print if /^\d+\:.+(\[\S+\:\S+\])/' | grep VGA

Your output will be something like that:

00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller]) 

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Chelsea LP [Radeon HD 7730M] [1002:682f] (rev ff) (prog-if ff)

Now look for the [VGA controller] at the end of each device. Whatever device has it, is the active GPU. In my case it's the i7 processor (HD 4000) that's handling the work.

share|improve this answer
Not really... lspci -vnnn | perl -lne 'print if /^\d+\:.+([\S+\:\S+])/' | grep VGA 00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller]) 01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK107M [GeForce GT 650M] [10de:0fd1] (rev a1) (prog-if 00 [VGA controller]) – Anne van Rossum Feb 22 at 16:55
@AnnevanRossum Did you get any solution to this? I have the exact same issue as you with two [VGA controller]. – Einar Sundgren Mar 5 at 20:38
@EinarSundgren I gave up bumblebee for nvidia optimus ( which allows you to switch with prime-select. – Anne van Rossum Mar 6 at 14:03

I found this (if you have NVidia and intel graphic cards):

I think the following command should give you an indication of your active chip:

$ glxinfo|egrep "OpenGL vendor|OpenGL renderer*"

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile*

If you switched to NVidia card:

$ optirun glxinfo|egrep "OpenGL vendor|OpenGL renderer"

OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GT 555M/PCIe/SSE2
share|improve this answer

On Ubuntu 15.10, after I installed nvidia-352 and the GPU seems to work:


shows something like:

enter image description here

Note how it shows:

GPU 0 - (NVS 5400M)

where NVS 5400M is my GPU model. This did not show up before I had installed the driver.

Also f I fire glxgears, the GPU usage goes to > 90%, further sign that it is working.

But the ultimate test is to do a benchmark and see your FPS go way up: How to perform a detailed and quick 3D performance test

Similar on Launchpad:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.