Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since I've upgraded my system to Ubuntu 11.10, Unity's global menu and search are having font rendering problems (no anti-aliasing, bad font sizes). No problem in sub-menus.

The font rendering problems do not appear on a newly created user. Just the ones which were existing before the upgrade.

What can I do to solve the rendering problems ?

share|improve this question
add comment

3 Answers 3

up vote 4 down vote accepted

I have found that to resolve this antialiasing problem you need to

rm ~/.config/dconf/user

In my case I had also lost the background and icons order, but it fixed after a reboot.

share|improve this answer
add comment

You can adjust the font settings using gnome-tweak-tool Install gnome-tweak-tool. Do note that installing gnome-tweak-tool also installs gnome-shell.

To install gnome-tweak-tool, you can run the following command in a terminal:

sudo apt-get install gnome-tweak-tool

After installing it, open the tool and go to Fonts. The configurations that you should be changing are 'Hinting' and 'Antialiasing'.

Information about the options available:

The type of antialiasing to use when rendering fonts. Possible values are: "none" for no antialiasing, "grayscale" for standard grayscale antialiasing, and "rgba" for subpixel antialiasing (LCD screens only).

The type of hinting to use when rendering fonts. Possible values are: "none" for no hinting, "slight" for basic, "medium" for moderate, and "full" for maximum hinting (may cause distortion of letter forms).

share|improve this answer
    
Thank you for this answer. I'll try to solve the problem this way on the next computer I'll upgrade. The 3 machines I've upgraded until now have had the problem. Meanwhile, I solved it by removing "~/.config/dconf/user" to completely reset the parameters. It is quite radical and some parameters must be reconfigured manually but it works... –  Golboth Oct 17 '11 at 21:09
    
Jokerdino's solution doesn't improve the antialiasing problem. Removing ~/.config/dconf/user does. –  Case Oct 23 '11 at 2:39
1  
From the Ubuntu forums [1], another solution using dconf-editor (from the dconf-tools package): modify the org.gnome.settings-daemon.plugins.xsettings key [1] ubuntuforums.org/showthread.php?p=11322965 –  David Planella Oct 23 '11 at 9:49
add comment

Try to set the Text Scaling Factor to something different from 1.0 (e.g. 1.1 for me is pretty good) and leave Antialiasing set to Rgba.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.