Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since 11.10 you can't change much in the appearance options, just the windows border styles but NOT the background colour like you could do it in Natty. For some odd reason as I upgraded to 11.10, it took the colour theme I had in 10.04! A greenish background which suited pretty nicely to my wallpaper and my custom emerald theme.

Now I have a mix of those colors, it looks HORRIBLE. I tried the gnome-tweak-tool but you can't customize the window background color.

Here and example how it looks like:

http://img841.imageshack.us/img841/397/70664173.png

Help would be much appreciated,

EDIT:

Okay I got it. For those who have the same issue, here is the solution:

http://blog.angeloff.name/post/11431459380/ubuntu-11-10-replace-the-default-and-annoying-orange

I just reset it to default the gtk-color-scheme entry.

share|improve this question
2  
Hi and Welcome to AskUbuntu - well done for resolving this. Please can you add (in 5 hours time) your solution as an answer. You will then be able to close the question by accepting it (click the tick box). This will also allow us to up-vote you so you can gain some "rep". –  fossfreedom Oct 17 '11 at 11:22
    
Related: askubuntu.com/questions/63488/… –  WarriorIng64 Nov 16 '11 at 11:56
add comment

2 Answers 2

First install dconf-editor if you dont have it already:

sudo apt-get install dconf-tools

And then run the dconf editor:

sudo dconf-editor

Browse to org.gnome.desktop.interface and locate: gtk-color-scheme

Edit the property to the colours of your choosing:

bg_color:#f0f1f2;selected_bg_color:#4677f0

The colours are in hexadecimal in the format #RedRedGreedGreedBlueBlue

For example:

  • Black = #000000 (None of any colour)
  • White = #ffffff (The maximum
  • of every colour) Red = #ff0000 (Red Only)

Happy Customising!

share|improve this answer
add comment

My problem with this new Ubuntu 11.10 was the fact that I was not able to change the background color of the windows, that white color just drove me crazy; as you noticed 'Appearance Preferences' from the old Ubuntu does not exist any more here.

There is a way though (or maybe more):; here's what you have to do to change colors in Ubuntu 11.10:

  • open the terminal, paste sudo apt-get install dconf-tools, then dconf-editor, then browse to org.gnome.desktop.interface.
  • Locate gtk-color-scheme, but don't click on it; click on the empty space on the right side to get a small box where you will paste the following: bg_color:#ebe0be;selected_bg_color:#737370;base_color:#9d906a. Then press Enter, nothing else!
  • The colors will change right away (this is just an example with my favourite colors).

If you want to find your own colors, install gnome color chooser and play with the colors (the color palette will look the same as it did in "Appearance Preferences" in the old Ubuntu) to find out the right codes (six-digit hexadecimal numbers) for the ones that you like. Once you find yours, paste the six-digit code number into the right place in gtk-color-scheme and then enter again. It is done. Enjoy it! It took me a whole month to figure this out.

share|improve this answer
    
If you want to grab the hex-color-code for a color from a picture (or anything that can be displayed) you can run 'sudo apt-get install grabc'. Then, you can just type 'grabc' in the terminal and your cursor will turn into a reticle for you to select the color. –  jwdinkc May 7 '13 at 16:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.