Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just reinstalled my Ubuntu system with 11.10, but ran into a problem when I tried to install Gimp 2.7.

I always get unmet dependencies (it's german, so I can't tell you the exact english translation):

Needs gimp-data (<= 2.6.11-z) but 2.7.3-2011082002~oo should be installed

I already read the follow post, but the answers didn't really help me.

When I type in

sudo apt-get install gimp=2.6

it just says that there is no version 2.6 found. I get the same with 2.7.

I really need Gimp. But installing Gimp 2.6 isn't possible as well.

When I remove the repos for 2.7, I still get the same error.

share|improve this question

6 Answers 6

up vote 3 down vote accepted

The following thing did it for some reason.

It seemed like the problem was a gimp-data 2.7 package, that was still installed after I removed the ppa ppa:matthaeus123/mrw-gimp-svn .

After I removed this package and then removed the ppa:matthaeus123/mrw-gimp-svn it installed gimp 2.6 immediately.

I tried to add the ppa again (to install 2.7, because I made a file with that and need to open it - which doesn't work with 2.6), but always got an error about a missing libbabl.0.so.0 file (although it was installed).

I also tried this ppa which I stumbled upon: https://launchpad.net/~alex-p/+archive/notesalexp-oneiric

I also checked the list of sources when I do an apt-get update, but it's not even in there.

At least I have one gimp.

But if somebody knows a trick that is worth trying, I'd love to hear it. (it has gimp 2.73 in it, but when I add it and also activate it nothing happens)

share|improve this answer

Try to install it again using this PPA: ppa:matthaeus123/mrw-gimp-svn

I installed GIMP this way without unmet dependencies problems.

share|improve this answer
    
This is the one I already tried. –  SimonEritsch Oct 17 '11 at 11:38
    
@SimonEritsch Ah, OK. Seeing Doug answer, there are no packages for amd64 in that PPA. Try to install this package (click on your arch in “Builds” section to download it). That package is outdated in the PPA, and that could be the cause of the problem. –  Fitoschido Oct 18 '11 at 17:45
    
thanks for you help. I posted my solution. –  SimonEritsch Oct 18 '11 at 19:42

If you want to use the ppa mentioned for gimp it only has i386 packages for 11.10, the amd64 failed to build quite some time ago.

If your on a 64 bit install then just use 11.10's version which is simply named gimp

share|improve this answer
    
Thanks for you answer. When I remove the ppa, I still get the same error. (I also did an apt-get update) –  SimonEritsch Oct 17 '11 at 11:41
    
Or do you have an idea what the problem could be. Is there a way for me to check if the amd64 packages are ready to use ? –  SimonEritsch Oct 18 '11 at 11:48
    
@SimonEritsch You can check the package page in Launchpad to see if there are builds for your arch: launchpad.net/ubuntu/+source/gimp –  Fitoschido Oct 18 '11 at 17:36
    
@Doug thanks for you help. I posted my solution. –  SimonEritsch Oct 18 '11 at 19:41

EDIT: Be warned that adding the repositories from my post here and updating your packages from there may BREAK your GTK+ settings (themes) and such.


Actually when you add the repository for matthaeus123 it indicates what needs to be done:

sudo add-apt-repository ppa:matthaeus123/mrw-gimp-svn

It mentions that there are packages in oneiric that need to be updated. So then add:

sudo add-apt-repository http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu
sudo add-apt-repository http://ppa.launchpad.net/ricotz/testing/ubuntu

That seems to fix the dependency problems.

If you are getting an error like this:

gimp: error while loading shared libraries: libbabl-0.0.so.0: cannot open shared

You can try fixing it by entering this into a terminal:

sudo apt-get remove libbabl-0.0-0
sudo apt-get clean
sudo apt-get install gimp
share|improve this answer

I'd appreciate not making any posts look like a solution when they are not (SimonEritsch's answer).

As I understand it there are no amd64 packages available yet (thank you doug for the information) and currently this would be the only proper answer to the original question.

As for the tip to try to install this - installation failed.

Related post http://ubuntuforums.org/showthread.php?t=1834302


EDIT: @imonEritsch

It did nothing. Probably you ended up with GIMP 2.6.x.

Here's a solution to install GIMP 2.7.4. Tested on ubuntu 11.10 x64.

1. Open the Terminal and issue the following commands:

sudo add-apt-repository ppa:matthaeus123/mrw-gimp-svn
sudo apt-get update

2. Run Software Center, search for GIMP, press 'More info' (it should already state that you're about to install 2.7.4) and install it without changing any options.

Now, the above is bit by bit what I did that gave me a working GIMP without any additional hassling but the following should work as well:

sudo add-apt-repository ppa:matthaeus123/mrw-gimp-svn
sudo apt-get update
sudo apt-get install gimp

Edit: The last 3 commands method confirmed working.

share|improve this answer

You need to remove gimp, gimp-data and libgimp 2.7.3 manually.
Remove the mattheus ppa and restart ubuntu. then you should able to install gimp 2.6.11. Good luck.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.