Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After upgrading to 11.10, the behavior of applications switcher (Alt + Tab) has changed. Now it displays applications across all workspaces. I have a lot of windows opened when working. I'm grouping opened applications to separate sets which are placed on different workspaces. This is how I found myself be more productive. But now it became totally time consuming, if I need click "tab" button more than 10 times while I reach some app.

How can I force the windows switcher to display only applications from current workspace?

share|improve this question
    
Duplicate? askubuntu.com/questions/68151/… –  fossfreedom Nov 12 '12 at 12:47
add comment

2 Answers 2

up vote 23 down vote accepted

For 12.04
By default the switcher in 12.04 only shows the applications in the active workspace.

For 11.10
The method described below does not force the Alt + Tab switcher to display applications from the active workspace but instead, display those applications next to each other. This would mean that you can switch to it relatively easily compared to switching between applications in all the workspaces.

You can change the behavior of the Alt + Tab switcher. There is an option in compizconfig-settings-manager Install compizconfig-settings-manager that lets you group the applications together from the active workspace.

To install CCSM, run the following command in a terminal:

sudo apt-get install compizconfig-settings-manager

To enable the setting, click on Ubuntu Unity plugin and select Switcher tab and tick Bias alt-tab sorting to prefer windows on the current viewport.

Unity plugin

Switcher option

This will ensure that the applications from the same workspace will get grouped together in the window switcher.

share|improve this answer
    
Thank you! I was thinking this could be Compiz issue, but I've lost between compiz settings as always :-) –  Pawka Oct 17 '11 at 6:55
    
It's disappointing that in order to fix Alt+Tab I have to install Unity and Compiz, two things I have no need for, slow down my system considerably, and which I DO NOT want to install. –  Cerin Mar 11 '12 at 5:49
    
@Cerin This method will only affect Unity's Alt +Tab configuration. So, I don't really understand why you are so annoyed. –  jokerdino Mar 11 '12 at 5:54
    
This method still works in 13.04 to revert the default behavior and show all applications from all workspaces. –  Keith Smiley Sep 13 '13 at 18:44
add comment

This is actually fixed in 12.04: "In 12.04, by default Alt-tab will only switch between windows on the currently visible workspace(s)."

See https://bugs.launchpad.net/unity/+bug/863399 for details.

share|improve this answer
    
Cool, not long left to wait for stable 12.04 release \o/. –  Pawka Mar 9 '12 at 7:04
add comment

protected by Community Mar 29 '12 at 15:15

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.