Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently upgraded to Ubuntu 11.10 and since then, I haven't been able to checkout code from Google Code. I can't get it with either svn or git, but they were both working before the upgrade (so I'm assuming it's a problem with 11.10).

SVN:

$ svn checkout https://project.googlecode.com/svn/ project --username me@gmail.com
svn: OPTIONS of 'https://project.googlecode.com/svn': SSL handshake failed: Secure connection truncated (https://project.googlecode.com)

Git:

$ git clone https://me@code.google.com/p/project/ 
Cloning into project...
Password: 
error: gnutls_handshake() failed: A TLS packet with unexpected length was received. while accessing https://me@code.google.com/p/project/info/refs

fatal: HTTP request failed

Any ideas?

git version 1.7.5.4
svn, version 1.6.12 (r955767)
openssl 1.0.0e-2ubuntu4
libneon27-gnutls 0.29.6-1

Edit:

Just confirmed with my 11.04 netbook that I can checkout Google Code via https with subversion.

I compiled subversion-1.7.0 from source using the neon 0.29.6 and openssl with no luck. It now gives svn: E175002.

Edit 2:

Just to be clear, I only seem to have this problem with Google Code. I can check out code from all of the other repositories that I've tried.

share|improve this question

3 Answers 3

up vote 2 down vote accepted

I also had this problem when moving to 11.10 (although with an Assembla SVN repo, not Google code). This solution from Jan Kester's blog worked for me:

sudo apt-get install libneon27
cd /usr/lib/
sudo rm libneon-gnutls.so.27
sudo ln -s /usr/lib/libneon.so.27 libneon-gnutls.so.27

Hope this helps.

share|improve this answer
    
It's weird, but I had run across this and tried it earlier. I attempted it again just for grins and apparently it works now. I guess I made a mistake. –  Jason Iverson Oct 25 '11 at 12:58

it's working fine here with the same svn version as yourself. Can you try backing up/removing/renaming your ~/.ssh and ~/.subversion folders and seeing if that helps matters.

I see that the above solved the same issue for other users on earlier Ubuntu versions.

share|improve this answer
    
Yea, I've already tried that several times. Forgot to mention it >.< (Tried it again just now to be sure though) –  Jason Iverson Oct 19 '11 at 23:22

Just use http:// protocol instead https:// if you can. Worked for me.

share|improve this answer
    
This worked perfectly for my needs this time, but I imagine some repositories are only available over an SSL connection. –  user39051 Feb 17 '13 at 5:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.