Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Had upgraded my laptop from 11.04 to 11.10, desktop ubuntu. And made fresh install of ubuntu server 11.10 on another comp.

And now a have exactly same problem on both computers:

It doesn't have working network after boot. ifconfig -a is saying that there is no IP address. Unplugging/plugging ethernet cable doesn't work. I have to make sudo dhclient -4 eth0 by myself to make it working, every time after boot. It helps, but it's annoying.

wtf? how to fix that?

PS everything worked fine on same network, just before upgrading to 11.10. Other devices still working on this network without any problem.

Update 1:

Had fixed this problem on laptop, there was no any configuration to ethernet network, at network-manager (and i'm sure that it was there, before upgrade). Just made new one, and configured it as 'auto-connect'. Seems that is working now.

btw, other my comp, didn't have 'Network Manager' and event graphical interface.

Update 2:

When i'm making sudo dhclient eth1 I get following in /var/log/syslog:

Oct 17 12:02:51 towerserv kernel: [  482.693427] ADDRCONF(NETDEV_UP): eth1: link is not ready
Oct 17 12:02:51 towerserv dhclient: DHCPDISCOVER on eth1 to port 67 interval 3
Oct 17 12:02:53 towerserv kernel: [  484.561428] sky2 0000:03:00.0: eth1: Link is up at 100 Mbps, full duplex, flow control both
Oct 17 12:02:53 towerserv kernel: [  484.561571] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
Oct 17 12:02:54 towerserv dhclient: DHCPDISCOVER on eth1 to port 67 interval 5
Oct 17 12:02:55 towerserv dhclient: DHCPOFFER of from
Oct 17 12:02:55 towerserv dhclient: DHCPREQUEST of on eth1 to port 67
Oct 17 12:02:55 towerserv dhclient: DHCPACK of from
Oct 17 12:02:55 towerserv dhclient: bound to -- renewal in 40855 seconds.
Oct 17 12:03:04 towerserv kernel: [  495.376004] eth1: no IPv6 routers present

Update 3

Fixed by adding following lines into /etc/network/interfaces:

auto eth0
iface eth0 inet dhcp
share|improve this question

In hope of getting interesting log messages:

Turn of network, wait 2 seconds, turn on network.

This should be situation where you don't have IP (check it please).

Post relevant sections of dmesg and /var/log/syslog.

Get ip with sudo dhclient -4 eth0.

Post updates to dmesg and syslog.

share|improve this answer
Hi! Make an update, have added /var/log/syslog after executing 'sudo dhclient eth1'. Btw, i'm not sure what sections of dmesg are relevant to this issue, and what i need to attach to my question. Can you suggest, please? – Igor Artamonov Oct 17 '11 at 10:03
Hi. From what I understand, you managed to fix the problem on your own (lack of network configuration)? – bbaja42 Oct 17 '11 at 11:35
yes, i've fixed it on one of my computers. Still have it in another one :( – Igor Artamonov Oct 17 '11 at 11:36
What happens when you restart network? Does it still not work? – bbaja42 Oct 17 '11 at 12:09
Has fixed it by editing /etc/network/interfaces, see Update 4. Thanks – Igor Artamonov Oct 17 '11 at 12:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.