Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since yesterday, when I upgraded Ubuntu to 11.10, I've had a very slow wifi connection. My route is a D-Link Dir 600. With Ubuntu Natty all worked fine. In fact on the same netbook, I have Linux mint 11 in another partition, and it works fine today. So I think is a problem between this router and kernel 3. Anyone have the same problem?

Thanks and greetings from Argentina!!!

PD     *-network               
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:05:00.0
       logical name: eth0
       version: 02
       serial: 60:eb:69:03:50:e0
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=N/A latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:42 ioport:2000(size=256) memory:f0520000-f0520fff memory:f0510000-f051ffff memory:f0540000-f055ffff
  *-network
       description: Wireless interface
       product: AR9285 Wireless Network Adapter (PCI-Express)
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:09:00.0
       logical name: wlan0
       version: 01
       serial: 1c:65:9d:21:f0:c4
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.0.0-12-generic firmware=N/A ip=192.168.0.10 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:18 memory:f0100000-f010ffff
share|improve this question

closed as too localized by jrg Feb 27 '12 at 13:02

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
I think the router is not a the problem; it's probably the wireless card (ore more accurately, its drivers in the kernel). Can you edit the question to include the output of sudo lshw -c network –  Oli Oct 17 '11 at 0:49
    
Welcome to Ask Ubuntu! We need more hardware information to help you, can you look at this question and then edit your question adding the information? –  Jorge Castro Oct 17 '11 at 1:16
    
I think the problem is the router, with the kernel 3, because I have good connection with another wifi router. I tested today in a friend s house, and the netbook worked fine. So, it is a problem between dir600 and ubuntu 11.10. –  Horacio Romo Oct 17 '11 at 2:37
    
The kind of thing you are describing : a router incompatible with the kernel, is merely impossible because every router communicate with every devices the same way (that's why you don't need any driver for a router) and if the kernel wouldn't be able to communicate correctly with your router then it wouldn't be able to communicate to any router. Either your router is kaput or it's your wireless/ethernet card driver that have problems. –  Nyamiou The Galeanthrope Oct 17 '11 at 3:13
    
Thanks Nyamiou, I think the same, but theese are the facts: before upgrade, I have Linux Mint 11 and Ubuntu 11.04 on the same netbook, both worked fine wiht the router. After upgrading, ubuntu 11.10 is very slow to conect, and Linus Mint is as fast as before. And second, when I connect ubuntu 11.10 with another wifi, it works. So what else can it be? And I test also Xubuntu, Kubuntu and Lubuntu 11.10. The same problem. –  Horacio Romo Oct 17 '11 at 9:55
show 2 more comments

2 Answers 2

I had similar problem with Netgear WNR2000 router and AR9285; solved reducing router speed from 300 MBPS to 54 MBPS.

share|improve this answer
add comment

Problem solved! After reading a lot, i decided to reset the router to the factory values, and to configure a new user and a new password. After that, the wifi connection runs very well on my Ubuntu 11.10, and in the other OS that i have in my house, like win7 or linux mint.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.