Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need to change the hotkeys for volume control, since I suffer from a bug, which disallows me to use the standard function hotkeys of my notebook.

Since I have updated I to Oneiric, I am not able to change the settings for the hotkeys. It is neither possible in system settings nor in gconf-editor.

Current buggy configuration: Volume mute: Fn + F3 Volume down: Fn + F4 Volume up: Fn + F5

Desired configuration: Volume mute: Ctrl + F3 Volume down: Ctrl + F4 Volume up: Ctrl + F5

If you need further information, I will be happy to provide it.


I tried to overwrite the standard settings by creating a new one in the “Custom shortcuts” category. Even this attempt is unsuccessful. Is there a possibility to access this menu as root?

share|improve this question

closed as not a real question by Bruno Pereira Mar 6 '12 at 17:54

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
May you please explain how it isn't possible? Do you mean you can't find the option, or that it is behaving weirdly? I'm asking because the option should exist in Keyboard›Shortcuts in System Settings. I just tested and on my end it does indeed allow me to set Ctrl+F3 to volume down. –  Dylan McCall Oct 16 '11 at 23:46
    
I can find the option without a problem as indicated in the picture below. But when I click on Volume mute and then press Ctrl + F3, it just don't work. I have no idea, why this happens and what's going wrong, but I tried several times to change this option in the system setting, but did not succeed. –  Daniel le Rouge Oct 16 '11 at 23:55

2 Answers 2

I am sorry to have bothered you. All I had to do was to double click on it.

share|improve this answer
2  
I don't think anyone is bothered -- this might help someone else at some point. –  belacq Oct 23 '11 at 22:57

Go to "System Settings" then "Keyboard" and the "Shortcuts" and select "Sound and Media". There you can change the shortcuts to whatever suits you.

Sound and Media

share|improve this answer
    
See the comment above and also the question: I tried exactly this and it did not work. Thanks for the help though! –  Daniel le Rouge Oct 16 '11 at 23:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.