Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have both monitors in portrait mode (i.e. they're vertical, not horizontal). Only one monitor shows an interface, the other is blank (white). I also do not know how to rotate the displays - I haven't seen an option for it.

OS: Linux-X86_64 (Ubuntu 11.10)

GPU: 2x Nvidia GeForce 550 Ti

Nvidia drivers: v280.13

Here is a screenshot of the one desktop that I can see (it's rotated by 90 degrees). Main screen

share|improve this question
    
Click on the Xserver display configuration, can you see your 2 screens there? activate the 2nd inactive one if you can, let me know how it went so we can proceed. –  Bruno Pereira Oct 16 '11 at 22:57
    
@brunopereira81 I do see the 2 screens, and I think both are already activated. This is what I see. When I click on the 2nd screen, the only difference is that "GPU-0" changes to "GPU-1". –  Dennis Oct 16 '11 at 23:11
    
What happens if you enable Xinerama? –  Nathan Osman Oct 17 '11 at 0:38
    
@GeorgeEdison If I enable Xinerama, I do not notice a difference. If I hit apply after enabling it, I get this error telling me it cannot apply. So I hit "apply what is possible" but still do not notice any change. Should I be saving changes to X Configuration file as well? –  Dennis Oct 17 '11 at 1:03
1  
this may help: unix.stackexchange.com/questions/113430/… –  virtualxtc Feb 4 at 8:47
show 4 more comments

3 Answers 3

I had the same problem with a 460. Try using TwinMode. Save the configuration to X without applying the changes. Logout and login, should be working then. It creates a virtual kind of monitor where Ubuntu detects your two monitors as one giant one made up of the combined resolutions. The top bar is a bit buggy with unity and the two screens, but the sidebar works perfectly. This is solution so far, but I'm currently looking for a better way.

share|improve this answer
    
I tried using TwinMode (TwinView?) but wasn't successful. Instructions are different everywhere I looked and those that I tried didn't work. I tried using Xinerama and saving changes without applying. That made it worse. I can now see something on both screens, but clicks register on one although the mouse is hidden, and the output is sent to the other screen - so I have to blindly guess where I'm clicking. Also, still no pivot working. This is a headache. Ubuntu is completely unusable for me on my desktop if there's multiple monitors involved. –  Dennis Oct 21 '11 at 5:01
add comment

I got my NVIDIA 550 TI with dual monitors running by adding the latest NVIDIA driver PPA.

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install nvidia-current nvidia-settings 

Reboot and then retry enabling the 2nd monitor again.

share|improve this answer
    
This succeeded in enabling the 2nd monitor, but I'm still unable to rotate the display using either the "displays" option in the control panel or NVIDIA's config tool. Is there any way to do this without me having to manually change the xorg.conf file? P.S. I'm now using Ubuntu 12.04. –  Dennis Apr 27 '12 at 3:27
add comment

Please note people the question is not just getting dual head to work, but getting dual head with pivot to work.

I believe the feature is not working at all. I spent At least a weeks getting trying to get it work for my external screen and nvidia setup.

Usually enabling pivot form the nvidia driver resets the session and takes me back to the login screen of unity.

If your graphics card support Nouveau and you find it to be a valid alternative. Install it. There pivo works like a charm.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.