Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Trendnet TK-209 KVM switch, and since upgrading to 11.10, I can no longer switch between systems using numlock-numlock from ubuntu. (I also tried scrlk-scrlk). If I switch manually to my windows box, I can get back to the ubuntu system with numlock-numlock, so it's not a problem with the keyboard or KVM switch.

Is there a setting that will allow this to work again, or an alternative keystroke? Failing that, is there a way to configure the switch to allow it to be triggered from ubuntu?

Edited to add:

This may be a gnome 3.x problem, since I tried booting with a Fedora Live CD and it was also unable to use either key sequence to switch over to the other system.

share|improve this question
    
I have the same problem, but I use Level One KVM switch - Num lock switch not working! –  user28635 Oct 18 '11 at 12:39

3 Answers 3

up vote 3 down vote accepted

I had the same issue and gleaned the answer from a post by George at http://beitis.net/ubuntu-kvm-switches-and-scroll-lock/

Basically, the workaround is to go to the console (Control + Alt + F1) and do the Num Lock there. I had to hit it 3 times to activate the switch. When you come back to this machine it will still be in the console so do Control + Alt + F7 to get to the GUI.

[edit] Nah, twice works too.

share|improve this answer
    
It seems like sometimes it's 3, sometimes 2 - not sure what's going on, but this is an acceptable workaround. –  chris Oct 19 '11 at 21:37

Also see alternative solution using numlockx and an sh script.

  1. Install numlockx

    sudo apt-get install numlockx
    
  2. Create a script on desktop (KVM.sh)

    #!/bin/bash
    numlockx on;
    sleep 1; 
    numlockx off;
    sleep 1; 
    numlockx on
    
  3. Create a custom keyboard shortcut to point to KVM.sh script (I used the key +K to execute this script)

See: http://ubuntuforums.org/showthread.php?p=11789416

share|improve this answer

A quick note:

Under the 12.04 final beta.

  • this now works as expected.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.