Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use digikam which suffers from a bug that means the editor loses its menu after the first launch. In 11.04 I could disable the global menu for digikam by launching it with:

APPMENU_DISPLAY_BOTH=1 digikam

However this appears to have stopped working in 11.10. Is there some other way to get an application to show the menubar in the window rather than the panel?

(Just checked and APPMENU_DISPLAY_BOTH=1 gedit does lead to gedit having a menu in the window. But maybe there is some other way?)

share|improve this question
    
I don't understand what the question here is supposed to answer, it looks like you've filed the bug, what are we supposed to do now? –  Jorge Castro Oct 17 '11 at 0:43
    
@JorgeCastro: I was wondering if 11.10 had changed the environment variable(s) it used to control how menus were displayed. I guess I could have made that clearer in the question. –  Hamish Downer Oct 17 '11 at 11:24
    
Nope, nothing in the variable has changed. Though it looks like it's a specific problem with digicam. :-/ –  Jorge Castro Oct 17 '11 at 12:22

2 Answers 2

up vote 1 down vote accepted

Your question is '..to disable the global menu in digikam'

What you've been doing previously is not disabling the global menu but enabling both the global & in app window menu. (which by the way should still work

To actually disable global on an individual qt4 app's you use this in various ways

QT_X11_NO_NATIVE_MENUBAR=1

For opening digikam from a menu, dash, ie. thru it's .desktop, then you simply edit the Exec= line in it's .desktop or if using unity & a quicklist the Exec= in the quicklist entry. Example on digikam's .desktop

gksudo gedit /usr/share/applications/kde4/digikam.desktop

Then use this as the Exec= line in the .desktop

Exec=env QT_X11_NO_NATIVE_MENUBAR=1 digikam -caption "%c" %i

For starting from a terminal you'd do this instead (or create an alias

export QT_X11_NO_NATIVE_MENUBAR=1; digikam 

For starting from Alt+F2 - a bit more complicated, probably not of interest here

As far as why you can't use your old 'both' method, not sure. If inclined to pursue I'd start by creating a new user, logging into it & seeing if it works there. If so it's something local to your user, you can track it down if desired with a little time & effort

share|improve this answer

From subscribing to the bug, someone reports:

Today I removed the package "appmenu-qt". All applications based on QT will start now without the global menu. All other apllications are starting with global menu. Digikam is working now, but I would like to have the global menu.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.