Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How can I deactivate Bluetooth on system startup?

share|improve this question
I don't think that "should be the natural default configuration", people are bound to want to use Bluetooth on their computers without having to turn it on (you don't seem to have a Bluetooth mouse or keyboard, if those were your primary input devices you'd want Bluetooth on from boot). However I do agree that a way to choose how you want Bluetooth to be on boot would be useful to have. – roadmr May 4 '12 at 20:25
The normal and natural thing is to let you choose, in the bluetooth settings, whether you want it on or off when it boots. It is not natural to have people turning it off or on every time they turn on their computer. We are talking about making Linux the best desktop system, not the worst, aren't we? – Robert May 4 '12 at 20:30
We agree that letting people choose is the best option. See here for some possible ways of doing this. – roadmr May 4 '12 at 20:31
Tell us what sort of bluetooth device you are talking about. Or is it built in to your laptop or netbook. – Tony May 4 '12 at 20:32
This is what works for me, on 12.04 – user60504 May 4 '12 at 20:45

23 Answers 23

Run sudoedit /etc/rc.local and add this before line with exit 0:

rfkill block bluetooth

You should still be able to enable Bluetooth through the top bar applet.

This should work for most systems but it looks like there are a few bugs lurking in the kernel's ACPI for Thinkpads. If you're on a Thinkpad, add the following to /etc/rc.local:

echo disable > /proc/acpi/ibm/bluetooth

Or check out ibm-acpi - IBM ThinkPad ACPI Extras Driver -- some reports suggest that ibm-acpi includes bluetooth control (amongst other nice things). But I don't have the hardware so I'm completely unable to verify these claims. Good luck.

share|improve this answer
For Thinkpads (and only Thinkpads) this works: echo disable > /proc/acpi/ibm/bluetooth in /etc/rc.local – Marius Gedminas Nov 2 '11 at 19:51
'rfkill block bluetooth' worked for Thinkpad Edge 15 – AlikElzin-kilaka Oct 9 '12 at 9:29
rfkill block bluetooth worked for Thinkpad T430u – bmaupin Nov 15 '13 at 16:47
Neither worked for me (ThinkPad x201) when I placed them one at a time in /etc/rc.local. The rfkill block bluetooth command does work, but not on startup. The -x flag is set on /etc/rc.local. I'm running Xubuntu 13.10. – Kyle Falconer Dec 20 '13 at 7:34
On Ubuntu 15.10 with systemd you need some more to reenable the use of the etc/rc.local file: – rubo77 Nov 10 '15 at 12:36

I found a how-to with a clean "workaround": (archive link for posterity)

Actually changing /etc/bluetooth/main.conf was enough for me.

From the article:

Search for the entry:

InitiallyPowered = true

and change the value to:

InitiallyPowered = false

was enough for me, although the article describes some other steps that may or may not be necessary.

share|improve this answer
doesn't work for samsung laptop 530u3b, bluetooth is always on after reboot and wake up – Maxim Kim Aug 27 '12 at 18:51
This would only work if I also used Saeed Zarinfam's answer of putting /etc/init.d/bluetooth stop in rc.local. It seems that when the service starts up, it also brings the power on for bluetooth. I needed both to get this to work. (ThinkPad x201, Xubuntu 13.10) – Kyle Falconer Dec 20 '13 at 7:57
Didn't work for me on thinkpad t420 – UpTheCreek May 10 '15 at 9:40
Shouldn't this be InitiallyPowered = false? – JellicleCat May 14 '15 at 0:32
"Search for the entry" is of precisely no use to those of us whose main.conf does not contain this parameter or any comment indicating its default location. So, under which [Heading] should we put it? – underscore_d Oct 30 '15 at 23:00

To disable the bluetooth driver from loading on startup:

sudo $EDITOR /etc/modprobe.d/blacklist.conf


blacklist btusb

Enabling it later should just be:

sudo modprobe btusb
share|improve this answer
Thanks for that, that does seem to work but I was trying to avoid command line stuff as per my original question. You would think this would be as simple as ticking a box so that it remembered that I don't want BT to start automatically but it looks like its way more complicated than that. With Ubuntu's drive for quicker boot times and the general focus on power consumption in laptops and netbooks I am suprised that this has never been addressed. I appreciate the help though. – Chris Giltnane Aug 19 '10 at 9:52
"Run gedit as root and edit /etc/modprobe.d/blacklist.conf" <-- ok, is that less command line for ya? – maco Aug 19 '10 at 13:35
Works fine on Samsung Q35 with Ubuntu 13.10, while the 'rfkill block bluetooth' approach does not. Thanks! – user27164 Jan 6 '14 at 8:29
DELL E6410 works for me. Good that can run again on the go without reset. – Ruslan Gerasimov Jun 13 '14 at 10:24

Step 1: Go to the terminal and type in the following command to edit system's /etc/rc.local file:

gksudo gedit /etc/rc.local

Step 2: Add the following line before the exit 0 line:

rfkill block bluetooth
share|improve this answer
This is set soft block to bluetooth, I think it same as turn off its service and works well. – Smile.Hunter Aug 17 '12 at 13:45
@Robert: $ man rfkill: "Disable the device corresponding to the given index." Despite the name, it is only disabling BT; just try the command rfkill block bluetooth on the terminal, you should see the icon go gray. – Daniel Jun 13 '15 at 17:54

Type the following into a terminal:

sudo gedit /etc/modprobe.d/blacklist.conf

At the bottom of the file, add the line:

blacklist bluetooth

Save the file and restart - Bluetooth should now be disabled.

share|improve this answer
This won't work on my pc... – Floqqi Oct 16 '11 at 21:47
@Floqqi: Can you please try it again? I've updated my answer. – Nathan Osman Oct 16 '11 at 23:42
Tried about 20 things on my ubuntu 12 thinkpad, this is the only one that did the trick. – OlivierBlanvillain Sep 12 '13 at 16:57

I think that the best way is to disable the service from being started in the first place. There is a general method for disabling services which works perfectly:

sudo sh -c "echo 'manual' > /etc/init/bluetooth.override"

That works for Ubuntu 13.10 and probably for earlier versions as well.

share|improve this answer
how to turn on bluetooth, while using provided settings later on? say I want to use it just for 5 min. every 10 boots.. – b1r3k Oct 10 '15 at 14:51

You can change the services started at boot with the help of BUM.

Install it: sudo apt-get install bum.

Run: sudo bum.

enter image description here

Uncheck the box and click Apply.

share|improve this answer
Thank you, desgua, I was thinking about this kind of tools. I have used some in the past but they become obsolete and the new ubuntu, with their minimalistic obsession, comes with nothing of the kind. Is this the only yo know or the best yo know? – Robert May 5 '12 at 0:15
It always worked fine so I never look for another tool... – desgua May 5 '12 at 0:21
Maybe works but at first it has disappointed me because it started showing the bluetooth as not activated at boot time, why? and as not running when rfkill, the applet and hciconfig show it running. I turn off and on but bum continues showing the service as off. I activated the service at boot-up but the status of the service continues to be wrong. – Robert May 5 '12 at 1:26
Sorry. I think BUM is not the way to set this then. My mistake. I don't have bluetooth to test. – desgua May 5 '12 at 1:30
sorry doesn't work on elementaryOS Freya – Hoang Tran Jul 9 at 13:31

I add

"/etc/init.d/bluetooth stop"



before "exit 0" command for boot with bluetooth turned off.

share|improve this answer
this worked for me, thanks! – woohoo Oct 12 '12 at 23:03
This removed the bluetooth tray icon but left my bluetooth indicator light on (indicating power was still being sent to the radio). Edit: this in conjunction with Stepbaer's answer (InitiallyPowered = false) worked for me. (ThinkPad x201, Xubuntu 13.10) – Kyle Falconer Dec 20 '13 at 7:59
this did not work on my 64-bit Ubuntu 14.04 dell inspiron. Only rfkill worked for me. – faizal Jun 17 '14 at 7:19

You can edit your update-rc.d settings. I used something similar to:

sudo update-rc.d bluetooth remove

In Debian Wheezy. Check out man update-rc.d for more info on how to use it.

share|improve this answer

Maybe you can turn it off in the Startup Applications. But these applications are hidden by default. Unhide the hidden Startup Applications in 12.04: Open the terminal and run these two commands:

cd /etc/xdg/autostart/

sudo sed --in-place 's/NoDisplay=true/NoDisplay=false/g' *.desktop

Now you can uncheck bluetooth. (Don't remove!)

share|improve this answer
Bluetooth is not listed among these applications, sadly. – pfctdayelise Jul 10 '15 at 12:11

No. It is not always in the startup applcations list. I think that the best solution is to add the rfkill command in rc.local script or to set the InitiallyPowered parameter in /etc/bluetooth/main.conf.

share|improve this answer
InitiallyPowered seems to be ignored for me. – UpTheCreek May 10 '15 at 9:42

1) Install the package smbios-utils and add it to Startup Applications with:

sudo smbios-wireless-ctl --bt 0

2) In terminal type:

sudo visudo

and add to the end of opened file /etc/sudoers the line:

<your username> ALL = NOPASSWD: /usr/sbin/smbios-wireless-ctl

3) To switch bluetooth on during session, run in terminal:

sudo smbios-wireless-ctl --bt 1

This works for me on my Dell D630 with Ubuntu 13.10

share|improve this answer
Do you think that sudo smbios-wireless-ctl --boot --bt 0 would work? Also, I'm not sure, but this may be Dell-specific. – Hitechcomputergeek May 2 '15 at 18:48
Actually, the package smbios-utils performs bios commands, so it switches on and off physical devices related to bios, so you may also use it to switch on and off wifi etc. I'm not sure if it works with any bios or not. At least, it works well with Dell. By the way, the last installations of Ubuntu 14.04 do same things with bluetooth and wifi applets, so I don't need any more in that package. – victor May 3 '15 at 19:22
I knew that. But if you do smbios-wireless-ctl --help, part of it has --boot Set BIOS boot-time setting. I didn't know they fixed the Bluetooth, though; thanks for telling me. – Hitechcomputergeek May 4 '15 at 21:29

I using Sputnik Kernel, which fixed this on my Dell Inspiron 14R N4110.

share|improve this answer

I think you should edit


and set


to disable the bluetooth service at boot

share|improve this answer
did not work on Ubuntu 14.04 – b1r3k Sep 27 '15 at 17:28

1. block bluetooth in rc.local

Add this line at the end of the file /etc/rc.local right before the line exit 0:

rfkill block bluetooth

This will do the trick, but only in older Ubuntu versions using upstart.

2. reenable rc.local on systemd

On Ubuntu 15.10 with systemd as startup manager the /etc/rc.local file is not used by default any more, so call this on a terminal:

sudo systemctl edit --full rc-local

Which opens an editor. At the end of the file i added:


Those changes are activated by

sudo systemctl reenable rc-local

Now the file /etc/rc.local is used as you know it.

3. disable blueman-applet on start

sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/blueman.desktop

Now blueman-applet is visible and you can disable it fon start

4. Reboot to see the effect

share|improve this answer

I add

"/etc/init.d/bluetooth stop"



before "exit 0" command for boot with bluetooth turned off.

share|improve this answer

I had to use a brute-force method to stop bluetoothd from being automatically started at boot. I renamed the executable so it couldn't be found.

share|improve this answer
It's faster starting things in parallel. At least that's the idea. – Douglas Leeder Sep 28 '12 at 13:48

There is a GUI way to disable services at startup. You can install Boot-Up ManagerInstall bum.

Boot-Up Manager

You can disable Bluetooth services from here.

share|improve this answer

Solution for my notebook

"BIOS - USB Configuration - EHCI2 : Disabled"

EHCI1 is for usb ports (actually My notebook has 2 usb 2.0 ports)

share|improve this answer

For those of you where inserting the line rfkill block bluetooth (or any other) in /etc/rc.local doesn't work, try to include the same line in the end of ~/.bashrc

In my set up (Ubuntu 14.04, Thinkpad W540), no option worked inserting it in /etc/rc.local but the former did work in bashrc. Note this will work just for the current user, not globally for all users.

share|improve this answer

Edit /etc/default/grub:

sudo nano /etc/default/grub

and change the following line:


to say this instead:


Then, update grub and reboot:

sudo update-grub
share|improve this answer

You can also use this Graphic application that also does this bluetooth manager

share|improve this answer

You need to disable it from the Start Up Applications list in System Settings.

Click on the cog in the top right hand side of the menu bar and then select System Settings.

Click on Start Up Applications then scroll down until you find the bluetooth setting, take the tick from the box and you all done.

share|improve this answer
I can't find bluetooth in the Start Up Applications.. – Floqqi Oct 16 '11 at 21:40
That doesn't actually stop the Bluetooth subsystems and hardware from running (and importantly: consuming battery). It just stops the applet running. – Oli Oct 16 '11 at 23:59
@Oli - thanks for the heads up, I never actually knew that ! I assumed if you disabled it in the start up applications it did not start the process at all. – Mark Rooney Oct 17 '11 at 9:44
Sadly, it's not in the startup applications in 11.10. – Amanda Jan 28 '12 at 1:24

protected by Community Oct 15 '14 at 14:26

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.