Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just did an upgrade (from 10.10 -> 11.04 -> 11.10) and am trying to get everything figured out.

I notice that when I log in, my name is [Invalid UTF-8]. Where is this coming from, and how can I fix it?

Update: I tried creating a new user under 11.10, but logging in as that user showed the same problem, so it's probably not related to the upgrade.

share|improve this question
1  
You are affected by this bug report: please subscribe to this to receive updates. bugs.launchpad.net/ubuntu/+source/indicator-session/+bug/834137 –  fossfreedom Oct 16 '11 at 22:38
    
What to do with questions that describe known bugs? this has been reported on Launchpad and as such is now closed. –  Marco Ceppi Jan 13 '12 at 12:56
add comment

closed as off topic by Marco Ceppi Jan 13 '12 at 12:56

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers

try to update the UID_MIN in /etc/login.defs

UID_MIN                  500

See also here: https://bugs.launchpad.net/ubuntu/+source/indicator-session/+bug/834137/comments/20

share|improve this answer
    
I don't want to have to re-create my user. –  chris Oct 22 '11 at 2:12
add comment

try to update the UID_MIN in /etc/login.defs

UID_MIN                  500

I tried the login.defs-workaround, but it does not work for me. And my user account already was UID 1000!

Perhaps this could be interesting. I updated two systems from Ubuntu 11.04 to 11.10: at the day of release I updated a 64-bit installation and one week later a 32-bit installation with a very similar configuration and very similar set of installed packages. Only the 64-bit installation does show this "[Invalid UTF-8]" bug. Both users (on both systems) has UID 1000!

share|improve this answer
    
I'm running 32 bit. –  chris Oct 30 '11 at 15:08
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.