Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Sometimes my system freezes when I use my external USB HDD (Western Digital 500GB). I am using a freshly upgraded Ubuntu 11.10 installation.

The freeze is not reproducable but always happens right after I unplug the device. The last time it happened right after I clicked the "Eject" Button in the Gnome Shell notification that appears when you plug in an external drive.

It is a real freeze, I have to hard reset the system when it happens.

Any ideas?

share|improve this question
    
Is this issue strictly with GNOME Shell? Have you tried reproducing these freezes under Unity? –  WarriorIng64 Oct 18 '11 at 6:46
    
Also, you may want to take a look at this Ubuntu Wiki page on troubleshooting freezes, and possibly report a bug for it. –  WarriorIng64 Oct 18 '11 at 6:48
    
It has never ever happened before I started to use gnome-shell. But I can't be a 100% sure that it is strictly a gnome shell issue since I switched to gnome shell 1 day after I upgraded to oneiric. So it may have something to do with the upgrade.. When I'm back home I will give my best to reproduce it in gome-shell / unity. –  imbaer Oct 18 '11 at 8:23
    
Vote to close as this seems to be a bug. –  htorque Oct 27 '11 at 8:29
add comment

3 Answers

up vote 1 down vote accepted

As per the launchpad bugs - Upgrading to 3.0.6 kernel should solve the issue. Deb packages are available from; http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.0.6-oneiric/

Installation Guide (for amd64)

  1. Download the kernel headers package;

    http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.0.6-oneiric/linux-headers-3.0.6-030006_3.0.6-030006.201110050043_all.deb

  2. And the appropriate package for your architecture;

    http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.0.6-oneiric/linux-headers-3.0.6-030006-generic_3.0.6-030006.201110050043_amd64.deb

  3. And the accompanying compiled kernel;

    http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.0.6-oneiric/linux-image-3.0.6-030006-generic_3.0.6-030006.201110050043_amd64.deb

  4. Install the files in the same order

  5. In the terminal run: sudo update-grub
  6. Reboot and select the kernel from the bootloader menu
share|improve this answer
add comment

I'm able to replicate the system freeze when using nautilus to un-mount a 1tb WD Passport.

I can safely remove it by calling

sudo umount /media/<MountPoint>
sudo /usr/local/sbin/suspend-usb-device.sh /dev/<disk> -v

The suspend script is available on github

share|improve this answer
    
Thank's for your answer, I'll check it out in a few hours. –  imbaer Oct 19 '11 at 8:30
    
What is interesting is I still get a freeze on my server using this script, but not on my desktop o_0 - so its not likely to be gnome related (server is headless) –  Thermionix Oct 19 '11 at 22:11
add comment

This is definitely a bug. It happens to me on Unity too. I tried the script suspend-usb-device but my system got frozen again.

Opened bug on launchpad: https://bugs.launchpad.net/ubuntu/+source/ntfs-3g/+bug/878294

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.