Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've updated to Ubuntu Oneiric and my workspaces are gone. Better put, keyboard shortcuts CTRL + ALT + LEFT/RIGHT arrow do not work now.

Is it possible that compiz is broken somehow? Can I repair it?

Note: I've used developer versions of Ubuntu Oneiric some time and just upgrade to latest version now.

Thanks for a suggestion!

share|improve this question
    
You can see your desktops using Super+s right? –  Bruno Pereira Oct 16 '11 at 19:51
    
Yes. But remaining workspaces are empty and I cannot move an app there. –  MartyIX Oct 16 '11 at 19:53
add comment

3 Answers 3

Check using CompizConfig Settings Manager (install if you dont have it) the number of virtual desktops assigned (horizontal and vertical size):

enter image description here

Then have a look at System Settings>Keyboard>Shortcuts>Navigation and check your assigned keyboard shortcuts there:

enter image description here

Try assigning new keys for them, if that works try reverting the original keyboard shortcuts.

share|improve this answer
    
I don't have options like: "switch to workspace X" (neither do I have "move to workspace left/right/...") in my dialog. –  MartyIX Oct 16 '11 at 19:54
    
Have a look at the edit: use ccsm to check the number of desktops you have. –  Bruno Pereira Oct 16 '11 at 20:02
    
If I set horizontal virtual size and vertical virtual size to 1 my ctrl+alt+<left/right> dont work even tough I can see 4 desktops using super+s. –  Bruno Pereira Oct 16 '11 at 20:05
    
I had number of desktops one. I changed it to 4 and nothing really changed :( –  MartyIX Oct 16 '11 at 20:09
    
horizontal virtual size and vertical virtual size were set on 2? –  Bruno Pereira Oct 16 '11 at 20:11
show 7 more comments

In my case I had to use gconf-editor and put Expo as the last plugin to load. I use hot corners though.

To do this you will have to install gconf-edtor, run it, then select 'apps' > compiz-1 > general > screen0 > options and double click on 'active_plugins'.

share|improve this answer
    
I did that. Am I supposed to restart Ubuntu? Or somehow apply changes? –  MartyIX Oct 16 '11 at 19:59
    
Unfortunately, it didn't help. –  MartyIX Oct 16 '11 at 20:17
    
That is indeed odd. What graphics card do you have? –  cprofitt Oct 17 '11 at 1:54
    
Does the graphics card matter? It worked in Natty just fine. –  MartyIX Oct 17 '11 at 18:57
    
I am not sure if it matters or not... but it might. –  cprofitt Oct 19 '11 at 12:05
add comment

I had a similar problem, but with non-standard shortcuts used -- icould only change left and down...

I solved it by going to to keyboard shortcuts (Now keyboard > shortcuts) and changing the shortcuts to something used for something else, and then back (a couple of times, sort of "jiggling it").

Try for example changing the "workspace left" to shortcut to Ctrl+Alt+Up and "workspace right" to Ctrl+Alt+Down, and then set all four again afterwards.

I have no idea why this worked.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.