Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
  • My built-in microphone doesn't work in "record audio" program and in Skype.

  • I'm using ubuntu 11.10 in Toshiba sattelite p505 s8980.

  • No mute button checked I have PulseAudio Volume Control installed currently when aim trying to use record audio program and hear what I record it plays noisy sound not my voice

  • I changed my computer from 'Analog Stereo Output' to 'Analog Stereo Duplex', in both sound setting ( ubuntu ) and in PulseAudio Volume Control

  • no problem in bios and in my windows seven sound worked perfectly and in ubuntu no problem in sound at all i can play music and movies and even in skype i can hear the sounf of who is taking to me ( it's about the microphone only "

share|improve this question

closed as too localized by jrg Feb 27 '12 at 12:12

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  Ringtail Feb 27 '12 at 8:51

3 Answers 3

I've had the same problem it's been driving me crazy.

Here's what worked for me edit the alsa options

If I run alsamixer I don't see any mic channels. (Press F4 for capture)

SCREEN SHOT REMOVED

sudo nano /etc/modprobe.d/alsa-base.conf

add the following line at the end

options snd-hda-intel model=laptop

Another post said restart alsa with sudo alsa force-reload. This does not work. Restart the laptop completely.

After restarting run alsamixeragain. This time F4 yields

SCREEN SHOT REMOVED

Notice that Mic B is selected for capture. Change that to Mic F

SCREEN SHOT REMOVED

That's it now the regular sound control should show mic input.

share|improve this answer

I've opened a terminal and type alsamixer. This will open the alsamixer in the terminal. Hit the 'F4'-key it showed me the 'capture' device settings. Then the 4th item displayed as Mic, I changed this to 'Internal Mic' (click array down/up key to change).

Once done, I checked in 'system-settings' --> sound --> hardware and I saw the missing lights appearing. Did a test with 'sound record' and this was working.

Hope this helps

share|improve this answer

Be sure that your audio profile is set to "Analog stereo duplex" in the System settings -> Sound configurations. This solved for me, because it was configured for "analog stereo output" only. You might want to change your audio profile only when you're going to use an HDMI output, for example.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.