Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After I updated from 11.04 to 11.10 the internet barely works. Loading a webpage can take minutes and thats even if it works in the first place. I have now idea if this is a bug and if it is how am I supposed to update? The internet doesnt work and just crashes! Please help.

Wireless card: TP-Link TL-WN821N

 00:00.0 Host bridge [0600]: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub [8086:2770] (rev 02)
00:01.0 PCI bridge [0604]: Intel Corporation 82945G/GZ/P/PL PCI Express Root Port [8086:2771] (rev 02)
00:1b.0 Audio device [0403]: Intel Corporation N10/ICH 7 Family High Definition Audio Controller [8086:27d8] (rev 01)
00:1d.0 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 [8086:27c8] (rev 01)
00:1d.1 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 [8086:27c9] (rev 01)
00:1d.2 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 [8086:27ca] (rev 01)
00:1d.3 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 [8086:27cb] (rev 01)
00:1d.7 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller [8086:27cc] (rev 01)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 PCI Bridge [8086:244e] (rev e1)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801GH (ICH7DH) LPC Interface Bridge [8086:27b0] (rev 01)
00:1f.1 IDE interface [0101]: Intel Corporation 82801G (ICH7 Family) IDE Controller [8086:27df] (rev 01)
00:1f.2 IDE interface [0101]: Intel Corporation N10/ICH7 Family SATA IDE Controller [8086:27c0] (rev 01)
00:1f.3 SMBus [0c05]: Intel Corporation N10/ICH 7 Family SMBus Controller [8086:27da] (rev 01)
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV790 [Radeon HD 4890] [1002:9460]
01:00.1 Audio device [0403]: ATI Technologies Inc HD48x0 audio [1002:aa30]
02:01.0 FireWire (IEEE 1394) [0c00]: Agere Systems FW322/323 [11c1:5811] (rev 70)
02:05.0 Multimedia video controller [0400]: Conexant Systems, Inc. CX23418 Single-Chip MPEG-2 Encoder with Integrated Analog Video/Broadcast Audio Decoder [14f1:5b7a]
02:08.0 Ethernet controller [0200]: Intel Corporation N10/ICH 7 Family LAN Controller [8086:27dc] (rev 01)
share|improve this question
Welcome to Ask Ubuntu! We need more hardware information to help you, can you look at this question and then edit your question adding the information. – Jorge Castro Oct 16 '11 at 18:54
Can anyone please help? – bmazoka Oct 24 '11 at 2:26
Please follow the instructions in the link I've posted so we can see more hardware information. – Jorge Castro Oct 24 '11 at 2:28
cross-reference TP-LINK TL-WN821N automatically disconnects – mario Oct 24 '11 at 2:54
I presume ubuntu 11.04 used older version of wireless driver. Have you tried using that older version instead? – bbaja42 Oct 24 '11 at 5:56

I had similar problems on my Thinkpad X1. Disabling wireless N solved that. What wireless driver/kernel module are you using?

options iwlagn 11n_disable=1
share|improve this answer
I'm on a desktop but using a wireless adapter TP-Link TL-WN821N – bmazoka Oct 16 '11 at 17:52
Unforchanitly this did not work – bmazoka Oct 24 '11 at 2:59
The file is "/etc/modprobe.d/ath9k.conf" and the line to add is "options ath9k 11n_disable=1". It works for me. – lenooh Apr 13 '15 at 16:09

In the future, I'd suggest buying hardware that's fully supported in linux to not deal with these issues:

Second, you listed your PCI cards, while apparently you have a usb wifi card.

However, if you look here, someone seems to have gotten your card working in 11.10

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.