Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgrade my Ubuntu to 11.10. I restarted and it worked perfectly until now when I restarted again and it is now in text mode after I login. Can somebody please provided some suggestions on what I should do? I do not understand what happened.

  • I tried restarting lightdm but it is already running.
share|improve this question
add comment

2 Answers

You could try restarting the graphical side by logging in in text mode and then typing the following command:

sudo service lightdm start

If that command gives errors, please add them to your question (using the edit link).

share|improve this answer
    
I tried what you suggest but it's doing nothing. It's showing me the following thing: start:Job is already running:lightdm –  debian Oct 16 '11 at 16:40
1  
Try hitting Ctrl+Alt+7 when you encounter the text-based login and see if the graphical login shows up. –  nitstorm Oct 16 '11 at 16:43
1  
@nitstorm: You mean Ctrl+Alt+F7. –  Nathan Osman Oct 16 '11 at 16:45
    
It's doing nothing –  debian Oct 16 '11 at 16:58
    
I tried Ctrl+Alt+F7 but it's doing nothing –  debian Oct 16 '11 at 17:16
show 2 more comments

I hit Ctrl+Alt+F1 then returning to Alt+F7, very inconvenient and I don't know what caused it, but it works.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.