Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I've just updated to 11.10 and now my embedded terminal in gedit does not match my default terminal. I hate looking at a white and black terminal. Does anyone know how to make the embedded terminal match the default terminal?

This is a screenshot:


I want my embedded terminal in gedit to match my default terminal.

share|improve this question

5 Answers 5

up vote 36 down vote accepted
  1. Make sure you have the following packages installed:

  2. Open up gconf-editor and navigate to apps ➜ gnome-terminal and select a profile:

    enter image description here

  3. Now open up dconf-editor and navigate to org ➜ gnome ➜ gedit ➜ plugins ➜ terminal and uncheck the use-theme-colors key:

    enter image description here

  4. From gconf-editor, copy the values of the

    • background-color
    • foreground-color
    • palette

    over to the corresponding keys in dconf-editor. The embedded terminal should now match a regular gnome-terminal.

    enter image description here

share|improve this answer
Thank you for the very detailed answer. Unfortunately when I am changing the values of the gedit terminal and then leave the edit text. The value I changed resets. Am I doing something stupid here? – Hugo Oct 20 '11 at 9:59
Wait I hit enter instead of unfocusing. Works great thanks. – Hugo Oct 20 '11 at 10:11
A great answer DoR, thanks. – Ingo Feb 12 '12 at 15:58
This resolves the white on white issue on Precise (likely bug with the Ambiance theme) – prusswan Mar 23 '12 at 22:40
In fact, the good way to do what you want to do is very close to the precedent solution, except on one little point. If you want to modify your palette colour of 'Gnome terminal', without re-modified it's value for the embedded terminal with dconf-editor, the solution is to simply delete the value of the palette with dconf-editor. Like in the precedent solution, which said to copy the value of the palette parameter, but just delete it (fill the value of embedded terminal plugin palette parameter to a blank). -- Naereen. – user73630 Jun 27 '12 at 17:24

This is for gedit 3

Same problem here white on light gray.

I manually edited /usr/lib/gedit/plugins/ Terminal used is xterm.

Search for:

fg = context.get_color(Gtk.StateFlags.NORMAL)
bg = context.get_background_color(Gtk.StateFlags.NORMAL)

I replace with

fg = Gdk.RGBA(0, 0, 0, 1)
bg = Gdk.RGBA(1, 1, 1, 1)

Info: fg = black text, bg = white background

share|improve this answer
I had to do locate to find it on 13.10. It was hiding at /usr/lib/x86_64-linux-gnu/gedit/plugins/ – Amanda Feb 13 '14 at 1:05

Make sure you haven't ticked Use colors from system theme then it should work:

enter image description here

share|improve this answer
This didnt work for me, I am running 10.04 if that makes any difference – Aly Apr 16 '11 at 10:05
Weird, because that's an updated live session of 10.04 in that screenshot. :( – htorque Apr 16 '11 at 11:59
I'm running 12.04 and I'm still having problems - can't read white on light gray. – phineas Jul 6 '12 at 15:55

Open gconf-editor and go to apps->gnome-terminal->profiles->Default

  • Uncheck the use-theme-colors option.
  • Set foreground color: #FFFFFF
  • Set background color: #000000

This will set the text to white and the background to black. It will set this for both the terminal and embedded terminal, if you would like to use different colors for each, then do this instead.

Open gconf-editor and go to apps->gedit-2->plugins

  • Create a new key named use_theme_colors
  • Set the type to: Boolean
  • Set the value to: False
  • Create a new key named foreground_color
  • Set the type to: String
  • Set the value to: #FFFFFF
  • Create a new key named background_color
  • Set the type to: String
  • Set the value to: #000000

Edit the file /usr/lib/gedit-2/plugins/

Underneath the line:

GCONF_PROFILE_DIR = "/apps/gnome-terminal/profiles/Default"

Add a new line:

GCONF_GEDIT_DIR = "/apps/gedit-2/plugins"

Then replace the lines:

if not gconf_get_bool(self.GCONF_PROFILE_DIR + "/use_theme_colors"):
fg_color = gconf_get_str(self.GCONF_PROFILE_DIR + "/foreground_color", None)
bg_color = gconf_get_str(self.GCONF_PROFILE_DIR + "/background_color", None)


if not gconf_get_bool(self.GCONF_GEDIT_DIR + "/use_theme_colors"):
fg_color = gconf_get_str(self.GCONF_GEDIT_DIR + "/foreground_color", None)
bg_color = gconf_get_str(self.GCONF_GEDIT_DIR + "/background_color", None)

Now you can the set the colors for the embedded terminal only, with the keys you created in apps->gedit-2->plugins

share|improve this answer

in 13.04, the gconf-editor path to the properties has changed to: org -> gnome -> gedit -> terminal

share|improve this answer

protected by Community Nov 22 '13 at 22:30

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.