Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

how could I repair? I update Ubuntu 11.04 to ubuntu 11.10, Im new user, help me Thanks

share|improve this question

closed as not a real question by Marco Ceppi Oct 16 '11 at 18:17

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Your question is too vague right now, what’s your network card model? –  Fitoschido Oct 16 '11 at 16:08
    
@Juan Please add more details to your question. Once you have edited your question to include things like: the type of wireless card, the speeds you're getting, the speeds you anticipate, any errors you've received, or any other details pertinent to this question. Then flag the question or reply to this comment and it'll be reviewed for reopening! –  Marco Ceppi Oct 16 '11 at 18:17

1 Answer 1

Since your description isn't very clear, this solution might or might not work.

On laptops, when on battery Ubuntu reduces the power given to the WiFi radio to save battery. There's a way to force Ubuntu to not make this change and instead give full power to the radio. To do this, run these command while on battery:

sudo iwconfig  

The output will be like this:

lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:"Network Wifi name"
Mode:Managed Frequency:2.457 GHz Access Point: 64:0F:28:1B:18:A9
Bit Rate=54 Mb/s Tx-Power=15 dBm
Retry long limit:7 RTS thr:off Fragment thr:off Power Management:on Link Quality=70/70 Signal level=-32 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:0 Invalid misc:137 Missed beacon:0

As you can see, wlan0 seems to be the WiFi interface and Power management under it is set to ON. You can fix that by disabling power management on the radio with this command:

sudo iwconfig wlan0 power off

This should fix it. If not, then its probably a driver issue. I cannot pinpoint the issue well because of the lack of information in the question.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.