Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After upgrading to kernel version 2.6.35 (went from 10.04 to 10.10), my wireless card stopped working. I'm currently using the Broadcom STA wireless driver (proprietary).

Have anyone found any fix to this issue besides using a previous kernel version?


share|improve this question
up vote 1 down vote accepted

Try installing the one from the Broadcom website. It's here. Follow the instructions in the readme.

Alternatively, try reinstalling the driver, it worked for me once.

share|improve this answer

By default when you upgrade from one release to another, all of the proprietary drivers are disabled. You need to use the 'Hardware Drivers' application to reenable them.

share|improve this answer

Neither reinstalling the firmware from the command line nor building the driver from source provided by Broadcom in @evgeny 's link worked for me when I had the same problem with my Compaq Presario V5000 with the B43 3418 chipset.

But using ndiswrapper did work. (I used the ndisgtk GUI and this driver)

share|improve this answer

There's a specific package available for B43 firmware -

sudo apt-get install firmware-b43-installer

That should auto-launch a quick update process which downloads the latest version and applies it. You shouldn't even have to access Jockey afterwards - it stops/starts the card on the fly.

share|improve this answer

If you can't get the Linux drivers to work, your best bet at getting the wireless card to work would be to install the drivers via ndiswrapper. You need to extract the .exe file for the Windows version of the driver and find the .inf file needed for setup.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.