Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 11.10 on my laptop, which has a Nvidia Quadro 1000M graphics card. At login, I chose the 3D version of Ubuntu, but somehow my laptop doesn't support this and switches to Unity 2D automatically. I think I might have a problem with my drivers. Is there a way to make Unity 3D work on my laptop?

When I try to run the unity_support_test test, I get:

Xlib: extension "GLX" missing on display ":0". Error: unable to create the OpenGL context

share|improve this question
    
Check this article to see if there is any problem with your drivers or hardware. –  jokerdino Oct 16 '11 at 15:01
    
Can you try installing the drivers and then editing your question with what happens? askubuntu.com/questions/47506/… –  Jorge Castro Oct 16 '11 at 15:08
    
Are there any other drivers showing up in the "Additional hardware drivers" dialog? You can reach it from the Unity (2D) Dash. I've also got an NVidia Quadro (NVS 110M), but it has been blacklisted for Unity as it seems to bring a lot of problems with it. My father's graphic card on the other hand (NVidia Quadro NVS 135M I think) can handle Unity without problems, though he needs the NVidia-173 driver to get it working. –  RobinJ Oct 16 '11 at 15:34
add comment

1 Answer

To make sure that your computer can run Unity 3D, type:

/usr/lib/nux/unity_support_test -p

If Unity 3D can be supported, you should have "Yes" responses to each of the items tested. It seems like you are probably going to get some "No" responses; please post the output here so we can get a better idea of the problems.

This is the output from mine:

file:///home/mdk/How-to's/ToSeeIfComputerSupportsUnity3D.png

Are you running the default drivers, or the Nvidia proprietary drivers? Open System Settings (under the "Gear Wheel" in the upper-right corner of the screen), and open Additional Drivers. It might be that there is a proprietary driver available if you enable it there.

share|improve this answer
    
When I try to run the test, I get: Xlib: extension "GLX" missing on display ":0". Error: unable to create the OpenGL context –  Martijn de Vree Oct 16 '11 at 15:01
    
I checked for any proprietary drivers. The additional drivers screen shows me that I can choose between the recommended Nvidia drivers and the post-release Nvidia drivers. I tried both, but still no succes... –  Martijn de Vree Oct 16 '11 at 15:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.