Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My fianceé has a AAO 751h. I've convinced her that, for that machine, Ubuntu (and/or derivatives) is a better choice than Windows (any version).

But now she wants to install Windows to play video files incoded with 'wmv9' because I can't get her notebook/netbook to run it (the audio plays ok, but not the video). I've already installed VLC, RealPlayer, Kubuntu-restricted-extras and the first codec package from mplayer download page.

When I test the same files in my notebook (which has the same software installed, but a differente hardware configuration), they run ok (both audio and video). Does anyone have a clue about what should I do? Thx in advance!

share|improve this question

closed as too localized by jrg Mar 1 '12 at 1:44

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
And you should also test with other media files and tell us if the same issue shows up with other video content. –  JanC Oct 13 '10 at 16:41
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. I am flagging this for closure :) –  Ringtail Mar 1 '12 at 1:40
add comment

1 Answer 1

The audio was coming out perfectly and the video was only a black screen; the problem was only with videos encoded with 'wmv9' codec. I tried other formats and a few streaming videos and they were working ok.

Now here's what I did to solve it: I saw this post and tried it. When I change the VLC video output for X11, it worked. I don't know why it worked and I can't even think why it happens, but it worked on my fianceé's AAO 751h.

Translation of the post:

For those who are looking for a way of displaying videos even after installing several codecs, you can try the suggestions of this two links (1 and 2). They basically say that one thing worth to try (and that solved my problem too) is to set either the whole system or the only the video-player to use X11 as the 'output' video.

In Ubuntu it can be done by (this I didn't try myself, I just copied and pasted here):

  • For gstreamer applications:

    • System --> Preferences --> Multimedia Systems Selector (If it's not there, you'll have to enable it by editing the menus.)
    • Click on the "Video" tab.
    • In the "Default Output" section, select X Window System (No Xv)` for the "Plugin".
  • In VLC it can be done by (that's the one I've done, but right now I can't remember the exact names of the tabs)

    • Preferences --> Video --> Output --> X11

References:

share|improve this answer
    
@Jorge Castro: OK, I'm going to post it right now, with the original links. Can you correct the technichal details that I will try to translate correctly? –  Gordin Oct 14 '10 at 14:21
    
@Gordin I'm upvoting your answer as its a usefull one. If you feel so, you can accept your own answer as well. –  marenostrum Oct 21 '10 at 17:38
    
If the same problem occurs with mplayer, vlc and gstreamer, it's probably a bug in the XV (xvideo) support of your graphics cars. In SMplayer, try using the "GL" output, which should be as fast as XV, but doesn't require XV. X11, on the other hand, is unaccelerated and thus might not play all video files. –  loevborg Feb 6 '11 at 21:10
add comment