Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two portrait mode monitors (the same model but one plugged in digitally, one analog). Both worked fine (as one big visual space) when I was on Maverick Meerkat.

When I installed 11.10 I only see one monitor working and it happens to be the digital one.

In gksu nvidia-settings I do not see any way to enable the other monitor.

In settings/displays only one monitor is shown and it is called "unknown", the "detect" button does nothing when clicked, the mirror setting is greyed out, and the orientation is "normal" and clicking it does not offer any other choices such as "portrait".

The motherboard is a Gigabyte GA MA 770 UD3.

share|improve this question
1  
Can you add what kind of video card you have? –  Jorge Castro Oct 17 '11 at 21:11
add comment

6 Answers 6

I also had some issues setting up dual monitors. Fortunately, the following procedure worked for me:

  1. Open nvidia-settings by searching for nvidia in the Dash, or run the command gksudo nvidia-settings in the Terminal. Note not to press the apply button.
  2. Under 'Xserver Display Configuration' select TwinView and configure the settings for the monitors to your liking.
  3. Click 'Save to X Configuration File' and an error message should appear. Click OK.
  4. In the next dialog box click the button to 'Show Preview'.
  5. Leave the preview window open and open a Terminal. Run the following commands in the Terminal to back up your xorg.conf file and open the original file in a test editor. If something goes wrong, just revert to your backed up xorg.conf.

    sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

    gksudo gedit /etc/X11/xorg.conf`

  6. Copy the text from the nvidia-settings preview window into the xorg.conf file. Save the xorg.conf file and close gedit. Click 'Cancel' to close the nvidia-settings preview window. Then click 'Quit' to exit completely out of nvidia-settings without applying or saving any data.

  7. Restart your computer. If all went well, the two monitors should work together.

When I was dealing with this problem, the original text in the xorg.conf file only had a section labeled "Device".

The text pasted from the nvidia settings creates this section for you. Therefore, you should transfer what was in the original device section to the new device section.

share|improve this answer
    
I don't know how to configure for "twin view". The program gksu nvidia-settings has an X Screen 0 and a GPU 0. Under GPU 0 there is a CRT1 (Syncmaster, with a refresh rate unknown) and a DFP 0 (Syncmaster, with various known values). There does not seem to be anyway to setup two monitors here. There is a feature to acquire an EDID file but when I click it, it seems to want to know the folder to save an EDID file. –  broiyan Oct 16 '11 at 14:01
    
Among the list of installed programs in Ubuntu 11.10, there should be a program called Nvidia X Server Settings. Assuming you have this program installed, when the program starts go to the item in the list that's called X Server Display Configuration. This is where you can configure multiple monitors. –  bwright1558 Oct 17 '11 at 2:13
add comment

I still had issues after doing what was posted above. Ultimately, this is what worked for me:

sudo vi /etc/X11/xorg.conf
Add the following as the last lines of 'Section "Device"'
Option "RandRRotation" "On"
Option "Rotate" "Left"
Change the 'Option "metamodes"' entry in 'Section "Screen"' to:
Option "metamodes" "CRT-0: 1280x1024_75 +0+1024, CRT-1: 1280x1024 +0+0"

This last line should be tweaked based on your monitor configuration. The '+0+1024' defines when/where the mouse will move from one monitor to the next.

share|improve this answer
add comment

i'm not sure if i'm posting this correctly but i tried the things you pictured and now both screens are worken.

though there is a problem every time i start up i get the following error:

none of the selected modes were compatible with the possible modes: Trying modes for CRTC 354 CRTC 354: trying mode 2560x1024@50Hz with output at 1280x1024@50Hz (pass 0) CRTC 354: trying mode 2560x1024@50Hz with output at 1280x1024@50Hz (pass 1)

after that, both screen do start but all the icons in my folders are all weird look. this is every thing has the same icon like folders and files.

I'm sorry i can't post a screen shot. this is because I haven't got enough reputation

regards,

Ietzen

share|improve this answer
    
i see now this is wrong but i couldn't comment the answer below –  Ietzen Oct 17 '11 at 20:44
    
See the above post: delete monitors.xml –  Victor S Feb 21 '12 at 15:02
add comment

See the following post: delete monitors.xml

worked for me.

share|improve this answer
    
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Imagine the linked site goes down for maintenance or forever - your answer would become worthless. –  htorque Oct 20 '11 at 14:19
    
Thanks, I used to get this errors popup window after login telling me some display settings could not be applied, even though dual monitor was working fine, but after deleting this fine, no more errors popup. Linux configuration is a total circus. –  Victor S Feb 21 '12 at 14:59
add comment
up vote 1 down vote accepted

I switched to Ubuntu 10.10. Dual monitors was easier to setup.

share|improve this answer
add comment

You might find an option in your BIOS to enable/disable "Optimus". If present you should try disabling it.

In my BIOS such a setting was present with the description "This is applicable for Windows 64-bit/32-bit. Disable it for all other OSes."

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.