Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Server stuck at black screen after reboot

i had just installed version 11.10 of ubuntu on my netbook. i have a intel gma 3150. the installation went well and there's no problem when using the demo mode.

After reboot when the installation finishes, the system wont boot even after trying both generic and recovery mode from the grub menu.however,i noticed that the hdd activity is still going on and i managed to get on to the login screen by putting the system to sleep mode and wake it up again but this is extremely inconvenient .

After much effort of trying such as uncommenting GRUB_TERMINAL=TERMINAL and GRUB_GFXMODE update intel graphics driver to latest, uninstall lightdm and uses gdm, disable plymouth, all the effort failed. the only thing work is nosetmode and i915.setmode=1 xforcevesa in the GRUB setting. i managed to boot straight in, but graphics acceleration, splash screen is lost. my default screen resolution which is 1024X600 changes to 1024X768 and i cant change it back. tried fresh installation for 5 times but problem still persist. can anyone help me please?

share|improve this question

marked as duplicate by Stefano Palazzo Feb 1 '12 at 11:36

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
I do have exactly the same problem, with a netbook with intel gma 3150. Did you find a solution ? Best regards. –  user29500 Oct 21 '11 at 8:28
    
what netbook do you have? if its a nvidia/intel optimus then this PPA may help - launchpad.net/~mtron/+archive/eee1015pn –  fossfreedom Oct 21 '11 at 8:43
    
alternatively - I know that support for your chipset is being worked on upstream - maybe adding the x-edgers PPA could help? launchpad.net/~xorg-edgers/+archive/ppa –  fossfreedom Oct 21 '11 at 8:45

1 Answer 1

This answer is exactly this one: Server stuck at black screen after reboot placed here for your convenience.

Maybe something wrong with the GPU feeding data. See this answer: Black screen after updating Ubuntu 11.04 and Mobility HD 4250 which leads to the X/Troubleshooting/Blank screen Wiki, containing useful information to solve these issues.

What I did to solve of GPU feeding data failure was editing the grub.cfg file by dropping the next in a terminal:

sudo gedit /boot/grub/grub.cfg

As mentioned on "Workaround B" in the Wiki page. Then remove the "splash" word on each grub's entry. And the problem was solved.

You can either edit grub.cfg file via Live Session with a CD/DVD or USB bootable. And there are some other workarounds that may help you.

There are some other workarounds on the Wiki Page.

I hope this give you a clue and you find a solution soon.

Good luck!

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.