Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've upgraded my desktop from Natty To Oneiric. Now the top panel has wrong theme and some indicators are missing (sound, power, etc.). Also, icons in launchers and on the desktop are missing or corrupted: screenshot

Logging with other users in same PC is no issue; in that case the top bar is correct. I've also filed a bug in Launchpad.

Is there a way to restore the bar?

share|improve this question
    
just delete or rename all hidden folders that starts with '.gnome' in your home directory . Then logout and login back. everything will be al right –  aneeshep Oct 16 '11 at 11:56
    
@aneeshep: it did not work. –  igi Oct 16 '11 at 13:32
    
It seems that it’s a GNOME Settings Daaemon bug. –  Fitoschido Oct 16 '11 at 14:59
add comment

3 Answers

If unity is a bit broken you could try resetting it - see this question for more details, but the short version is to open a terminal and type:

unity --reset

Also it might be worth uninstalling the nautilus-open-terminal package if you had it installed - this caused compiz crashes (launchpad bug) which might lead to your problems. The fix is currently in the oneiric-proposed repository, and should be generally available soon, but not quite yet.

share|improve this answer
    
Resetting Unity does not lead to any improvement. Also, nautilus-open-terminal is not installed in my system. –  igi Oct 16 '11 at 18:22
add comment

Three separate issues ..

(1.) Unity Launcher

This button-bar (right-hand of screen) replaces the menu system available as 'Classic' in Ubuntu 11.04 (Natty). You can try an go back, but I'm not sure I recommend it.

see: http://www.webupd8.org/2011/08/installing-using-classic-gnome-desktop.html

(2.) missing icons (on button bar)

The default theme is flawed, after upgrade to 11.10 (from 11.04).

Click on top right corner icon; 'Systems Settings' > Appearance > choose 'Radiance'

(3.) missing icons (on desktop)

This is going to require more effort.

By 'default' Ubuntu 11.10 and Unity (3D) does NOT use the desktop (and icons), but instead used the launcher. This is a work in progress ..

share|improve this answer
add comment
up vote 0 down vote accepted

I found the workaround here:

sudo rm /usr/share/GConf/gsettings/pythonconsole.convert
gsettings-data-convert
gnome-settings-daemon

Then, to solve definitely at every login, I had to create a launcher to gnome-settings-daemon in my home folder and add it to my startup applications.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.