Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How to install the driver for Atheros AR9285 in Ubuntu 11.10.

Still no package for 11.10 according to this

Here is the output of the commands

marc@fer-VPCYA1V9E:~$ sudo lshw -class network
  *-network DISABLED      
       description: Wireless interface
       product: AR9285 Wireless Network Adapter (PCI-Express)
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 01
       serial: 4c:0f:6e:d6:65:cc
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.0.0-12-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 memory:d3400000-d340ffff
       description: Ethernet interface
       product: AR8131 Gigabit Ethernet
       vendor: Atheros Communications
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: c0
       serial: 54:42:49:a2:1f:bc
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion= firmware=N/A latency=0 link=no multicast=yes port=twisted pair
       resources: irq:43 memory:d2400000-d243ffff ioport:1000(size=128)

And the second command

marc@fer-VPCYA1V9E:~$ rfkill list
0: sony-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: sony-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
4: acer-wireless: Wireless LAN
    Soft blocked: yes
    Hard blocked: no

Is there a way to make it work?

share|improve this question
Please have a look at this answer and let me know if it resolves your issue. Otherwise - add to your question the results sudo lshw -class network and also rfkill list – fossfreedom Oct 16 '11 at 20:58
possible duplicate of How do I get an Atheros AR9285 wireless card working? – fossfreedom Oct 17 '11 at 19:06
same issue (AR9285, 64bit) under discussion in:… – david6 Apr 7 '12 at 0:50
Possible solution: which may resolve this for you. – david6 Apr 7 '12 at 0:53

I fixed it. Edit the following file


and add this

blacklist acer_wmi

Then reboot and your wifi should work ;)

share|improve this answer

I have just solved the wireless problem on Lenovo B560. However, I'm a beginner into Linux, and didn't immediately figure that blacklist acer_wmi can only be added by running the command:

gksu gedit /etc/modprobe.d/blacklist.conf
share|improve this answer

The ath9k driver is included, and I can verify it's working -- wlan0 exists. However, the device cannot be switched on in the System Settings.

Mercifully, it was plug-and-play to cable-tether my Dell Streak.

share|improve this answer

The ath9k is included by default with latest linux Kernal. If you are interested in building latest one on your own. You can Google for "compact wireless linux driver"

share|improve this answer

I had the same problem as @fernando with wifi drivers for Atheros AR9285. After spending 6 hours trying editing blacklist, various backports, compat drivers and even once compiling newer kernel version.

rfkill list all used to show

Wireless LAN
  Soft blocked: no
  Hard blocked: yes

The thing which solved my case was setting the wifi ON using hardware switch.

Try it: Boot into ubuntu in recovery mode and select enable networking

Reboot and all is done. I then had Hard blocked: no and my wifi started working

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.