Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install Foxit reader.

I've downloaded the .deb, opened with Ubuntu Software Center (or gdebi, etc) and clicked install.

The progress bar do her job and an icon appears when I search for Foxit on launcher. It is also present in the menu, in Synaptic manager, and is seen by other launcher application like Synapse.

synapse, foxit

But it doesn't start.

It is not present in usr/bin and is not seen by alt-f2 (run), so it is not properly installed.

If I open again USC, FoxitReader appears as not installed. Restarting the deb file in gdebi it does not seem installed (the note that a version is already installed, and the options of reinstall, remove etc are all absent).


share|improve this question

I had the same problem and found a solution that worked for me.

The issue with Foxit reader is that it only does a 'partial' install and misses the main executable file that allows it to run.

There is a fix for this - after running the install via USC you need to extract the executable that is located in the /usr/bin/ folder from the .deb file you have downloaded using the Archive Manager.

Extract the Foxit executable to your home folder then run sudo cp FoxitReader /usr/bin in a terminal and Foxit reader should now work as expected.

Steps to follow with screenshots can be found here

share|improve this answer
This works indeed and the instructions are very detailed. – Alfred M. Aug 23 '12 at 8:14
It worked for me too... – Luis J. Romero Aug 31 '14 at 3:56

Certain software may not show up in application menu , because they don't necessary have to. e.g You only need to open a file by clicking on it , why bothering display it in app menu ?

To verify if a *.desktop is installed:

(i) find package name: dpkg -l | grep foxit -i

(ii) list contents: dpkg -L PACKAGE_NAME

So far just try some PDF docs , right click and see if you can choose another application rather than default PDF viewer.

And you may add the binary file from FoxitReader to the list , and it will be the default PDF reader after that.


See the pic below , did you try run FoxitReader (i picked 1.1 version from website)


share|improve this answer
If I right-click a pdf file i've the option "Open with FoxitReader" but nothing happens if I chose to do so. Same problem i f I click on FoxitReader icon on launcher. – Jonathan Oct 16 '11 at 17:05
@Jonathan , then you'll need to find the *.desktop file from that package , did you find one ? often /opt/foxitreader/foxitreader , see if that binary file is executable – warl0ck Oct 16 '11 at 23:00
@Jonathan , please see my update – warl0ck Oct 16 '11 at 23:14
Hi, I've found the .desktop file at usr/share/applications and was not executable. I've given exe permission but did'nt work. Error message fail to execute process. File or directory doesn't exist (more or less, i've ubuntu in spanish...) Oh, and no FoxitReader at /opt – Jonathan Oct 17 '11 at 10:06
see my picture , try directly FoxitReader , it's located in /usr/bin , i made a mistake – warl0ck Oct 17 '11 at 12:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.