Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed ubuntu 11.10 on my laptop yesterday, everything worked fine except for the wireless, which is very very slow compared to xp on the same machine.

I didnt have this problem when using older versions of ubuntu i.e. (10.04, 10.10, 11.04). I'm using intel AGN 5100 (I think the linux kernel had integrated support for this network card), on a hp presario cq45. Any suggestions on how to make it faster?

share|improve this question
    
This looks like an often problem. It's the same on my laptop and I searched for solution, but none of that worked. Hopefully it will be fixed soon. You can try loading the old version of kernel by choosing in GRUB –  tsusanka Oct 16 '11 at 14:31
add comment

2 Answers 2

up vote 1 down vote accepted
  1. First method : You need to disactivate IPv6, to do that, open terminal and enter the following commands:

    echo "#disable ipv6" | sudo tee -a /etc/sysctl.conf
    echo "net.ipv6.conf.all.disable_ipv6 = 1" | sudo tee -a /etc/sysctl.conf
    echo "net.ipv6.conf.default.disable_ipv6 = 1" | sudo tee -a /etc/sysctl.conf
    echo "net.ipv6.conf.lo.disable_ipv6 = 1" | sudo tee -a /etc/sysctl.conf
    

    Then restart your system. If you still have the issue, follow also instructions on step 2.

  2. Second method: A second solution for this issue can be by using the following :

    Open terminal and enter the following command:

    sudo -s
    gksu gedit /etc/modprobe.d/ath9k.conf
    

    That will open a gedit config file. At the end of the file add this:

    options ath9k nohwcrypt=1
    

Save an restart your OS.

(source: http://www.unixmen.com/linux-tutorials/linux-distributions/linux-distributions4-ubuntu/1785-resolve-slow-connexion-when-using-wifi-in-ubuntu-1104-natty-narwhal)

share|improve this answer
    
How does blacklisting an atheros module improve an intel card? –  Jorge Castro Oct 18 '11 at 2:11
add comment

Acording to this discussion the main problem is in wireless mode. If you are able to change your router settings, change the router mode to 802.11g. Than everything should be ok. Of course this is not solution, but you'll be at least able to use the internet at home (meaing: where you can change those settings). However this looks like a bug in 11.10 and hopefully will be fixed soon.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.