Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Please fine below the image. enter image description here

In this, you may observe that though libre writer is up, unity launcher does not have blue arrow. And clicking on it, does not bring back the application window.

Any pointers. I am on 11.10.

share|improve this question

closed as off topic by Stefano Palazzo Feb 7 '12 at 15:28

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

4 Answers 4

This is a known bug: https://bugs.launchpad.net/unity/+bug/842566

It's pretty annoying, and in 11.10 you also can't switch to LibreOffice via alt-tab - it just doesn't show up. Installing "lo-menubar" doesn't necessarily help, and indeed it can make things worse, since when maximized LibreOffice applications won't show their own menu bar nor the global menu bar, making it impossible to even close the window without resorting to keyboard shortcuts.

You can restart Unity for a very temporary fix, but sooner rather than later it'll happen again, sometimes right away.

share|improve this answer

I am experiencing this bug too. Just restart unity. Run the command unity --replace. This works for me every time.

share|improve this answer
    
Have you filed a report? It won't get fixed unless someone reports it and some of those bugs can be really difficult to find, so the more users report it, the easier it will become to hunt it down. If it isn't already reported, can you please do that and update your answer to contain a link to it? –  Jo-Erlend Schinstad Oct 16 '11 at 8:52
    
how do you file a report? –  Evan Oct 18 '11 at 7:32
    
Ask that as a separate question. It's a good one, and generically useful, so let's enable the community to provide some good answers. :) –  Jo-Erlend Schinstad Oct 18 '11 at 22:40
    
I too have noticed "misbehavior" but it's hard to describe and to reproduce. For me, it's always been Writer. Never an issue with Calc. I don't use the rest. Is there a less formal place to write about what we feel is not behaving so that a proper report can be formulated, perhaps collecctively? –  user25656 Jan 12 '12 at 10:27

According to this page, support for the global menubar (and I assume the Unity launcher goes along with that) was intentionally not put in for the 11.10 release, citing stability concerns.

You can install support separately via the lo-menubar package: sudo apt-get install lo-menubar

I installed the package and it seems to work great so far.

share|improve this answer
    
Installing lo-menubar can bring its own problems. Here's a list of bugs: bugs.launchpad.net/lo-menubar. –  user25656 Jan 12 '12 at 10:19

In my case it helped to install a newer version of bamfdaemon, libbamf3-0 and libbamf0

  1. Get the packages from
    https://launchpad.net/~unity-team/+archive/staging/+sourcepub/2124839/+listing-archive-extra
  2. Install with sudo dpkg -i <packages>
  3. Kill the bamfdaemon with killall bamfdaemon

Libreoffice now should show up in the Unity-Panel and in alt-tab.


(Credits to https://bugs.launchpad.net/bamf/+bug/842566/comments/64)

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.