Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I started what I thought was a standard upgrade, using the normal gui stuff. Part way through, it apparently put up a dialog asking if I wanted to keep the old apparmor config file or not. I was not at the console. The the screensave apparently kicked in. Then it appeard totally dead.

I tried several things, but it appears that the combination broke the upgrade.

On a second machine I was also doing the upgrade. On it, I just killed gnome-screensaver AND NOTHING ELSE. The got in with vnc (actual screen/kb unresponsive) and it appears to be going. Maybe to completion.

On the first machine, I think I had queued up an Alt-F1 before getting screensaver killed, and I could not get the gui back. So I eventually rebooted.

How can I resume the upgrade, repair the installation do something so I don't have to reformat all the partitions and start over?

That would be suboptimal.

share|improve this question

I've learned some more.

I started two upgrades, both amd64 11.04 to 11.10, using standard gui prompt.

One machine is a Dell OptiPlex 745, 2 core Pentium D, the other a Shuttle x27d, an Atom D510.

The installs both "crashed" at similar points: Some user feedback was required (the OptiPlex needed an answer to whether it should replace or leave alone some NetworkManager config file; the Atom needed an answer to similar question about apparmor config file) and the screen timed out. The screen saver came on (it's just to black, turning off the display) and then the machine appeared to be frozen. Wiggling mouse, hitting various keys and so on had no effect. Getting in with vnc and poking gui buttons and so on had no effect. Logging in with ssh, ps showed gnome-screensaver --nodaemon eating up vast time.

I googled a bit and tried various Alt-F1 kinds of things on the OptiPlex to no effect. Googled some more and learned that I should probably have killed the gnome-screensaver before doing anything else.

I had not yet done anything to the Atom. I logged into it with ssh, killed the gnome-screensaver. The screen was still dead on the actual machine, but when I went in with vnc I was able to poke the button that it appeared to have been waiting for; the installation proceeded and now it seems to be alive with everything as expected in the upgrade.

Unfortunately, when I got around to trying to fix the OptiPlex and killed gnome-screensaver, whatever keystokes I had given it had queued up and caused all hell to break loose. I eventually got to the point where I saw no choice but to reboot.

It would not come up. It hung early, with no clue about where.

More googling led to a successful reboot on the previous (11.04) version of things. I then did the google-suggested sudo apt-get update && sudo apt-get upgrade and that led to some dpkg thing that ended up doing the complete upgrade successfully using command line.

So it's all better now.


Now I face the irritation and annoyance that the Powers That Be think my computers ought to look like iPhones rather than computers.


Thanks to anyone who thought about trying to help.

share|improve this answer
If your answer here completely resolves your issue, you should accept it so we know the question has been solved. Thank you! – Christopher Kyle Horton Oct 29 '11 at 18:55

FWIW I had my laptop die at about 95% of the upgrade process (my fault - tried to squeeze it into remaining battery time).

Got grub to give me a text login and fumbled around with dpkg and apt-get upgrade and finally got the process to complete. 11.10 now works but having to relocate 3rd party drivers for a few of my devices.

Hope that gives you a start point / some ideas. The key was to get to the text login so I could run the commands. Oh - and I had to plug the laptop into a wired ethernet port and run "ifconfig eth0 up" in order to pull the files via dpkg / apt

share|improve this answer
Probably you should add what exactly you did with grub and how you "fumbled around" so that others can actually benefit this answer – cfi Oct 29 '11 at 17:11

This answer is likely unrelated to your question but here's what I did to get up to a running Ubuntu 11.10 during an abandoned upgrade from Ubuntu 11.04.

What happened:

  • Started with ubuntu 11.04
  • Chose "Upgrade to 11.10" in update manager
  • Everything downloaded just fine and packages started installation
  • When suddenly: No more actions, output of the update froze, last line of output was "libcups2", the mouse still worked, I could move windows, start (the old) firefox and do some other stuff - like figuring out what happened
  • Several applications were broken in this state of limbo. A terminal would no longer come up

Here's what I did:

  • Pressed Ctrl-Alt-F2 which switches to a TTY text console (Press Ctrl-Alt-F7 to switch back to your X deskopt showing your Ubuntu graphical desktop)
  • Logged in with user / password
  • typed: sudo su -
  • and entered user password to become root in this shell
  • dpkg --configure -a
  • to have all packages continuing their setup work
  • At this point networking was still not working, but I was getting my hopes up because at least I saw the linux kernel 3.0 being configured, an initrd written, and grub reconfigured
  • So I rebooted by typing init 6
  • I could now login to an Ubuntu 11.10 Unity desktop (yuck used gnome before) with my usual username/password and everything seemed to work
  • Nevertheless I opened again a terminal, sudo su - again and ensured that I had all Ubuntu 11.10 packages by running
  • apt-get update
  • apt-get upgrade
  • Actually no additional packages were retrieved. Then I did a
  • dpkg --configure -a
  • which caught a yet unconfigured adobe flash plugin. The plugin upgraded itself, which it could not do before because before the reboot the network was broken.
  • Everything looked good from here - I'm typing this answer right now at this point in time.

So, other things may crop up in the future that have been broken in this process. But overall I was pleasantly surprised that I did not have to reinstall from scratch.

So, fear not, help is not far away - usually.

I am very disappointed though because for me the quality of the distribution has deteriorated. I don't understand why I am again pushed to switch to unity even though I've already disabled it in 11.04. sigh But I can live with disabling it again...

Hope this helps whoever stumbles upon this question (it was very high ranked on google for several searches for "ubuntu 11.10 upgrade" combined with "hang", or "crash".)

Oh, and there was this bug which I think might be unrelated to my problem, but came up during the search nevertheless.

Good luck to everybody!

share|improve this answer

I had a dead machine from the upgrade failing but then I downloaded the Live CD which provides various options including upgrading...

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.