Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to enable the System tray icon for Pidgin in Ubuntu 11.10 (with Unity), but I don't see it.

I have to start it again and again from the launcher panel or from the dash.

Is there a workaround to show the system tray icon in Unity? I think it's the same behavior for Skype and some other applications also.

share|improve this question
    
martu's solution works for 12.04, shutter icon revealed –  serge Apr 10 at 7:37

6 Answers 6

up vote 33 down vote accepted

For 12.10 and older:

execute:

gsettings set com.canonical.Unity.Panel systray-whitelist "['all']"

(from http://www.webupd8.org/2011/10/things-to-tweak-after-installing-ubuntu.html)

and remember to set the system tray to "always" in pidgin preferences.

enter image description here

If the change doesn't take effect immediately, run unity --replace

share|improve this answer
1  
This fix worked once for me, but I've since lost my system tray icon (even after repeating the fix). I added myself to the list of people affected by bugs.launchpad.net/ubuntu/+source/pidgin/+bug/879950 –  Adam Monsen May 6 '13 at 16:40

For 13.04:

The migration of Pidgin to the new libmessaging-menu API, which caused this issue, is now done for Pidgin, but still under testing. Also, only a Ubuntu 13.04 package is provided so far, but since it does not introduce any dependencies on other stuff from 13.04, I was able to just install it from the PPA of the programmer who fixed it. According to his instructions, this is what fixed it for me:

sudo add-apt-repository ppa:jconti/gnome3
sudo apt-get update
sudo apt-get install pidgin-libnotify

You should now have pidgin-libnotify version 0.14-9ubuntu1. In addition, you have to add the following line to /usr/share/applications/pidgin.desktop:

 X-MessagingMenu-UsesChatSection=true

Then restart Pidgin, it should now get an entry in the message indicator menu of the panel again, so that when closing its window, it stays running.

Update

It is NOT necessary (any more) to install this repository as of May 23. Probably the updates have been officially included by now.

Just make sure the libnotify plugin is active! With Ubuntu 12.10 (and previous) and the whitelist for system tray icons you/the user may have deactivated the libnotify plugin on purpose.

share|improve this answer
    
That PPA doesn't seem to have build for Raring. –  Ondrej Slinták May 1 '13 at 10:16
1  
I tried the suggestions on my Raring installation, but it seems it doesn't work. –  Swarnendu Biswas Sep 17 '13 at 2:49

In 11.10 Unity has hidden the system tray access to pidgin under the messaging icon that looks like an envelope. If you click it, there should be an entry for Pidgin. Not exactly what you're looking for, but at least it's accessible somehow via the system tray.

share|improve this answer

manually:

  1. run dconf-editor
  2. open desktop -> unity -> panel
  3. set systray-whitelist to "['all']"
share|improve this answer
    
Thanks this tweak resolved my problem for a different app! –  subeh.sharma Jan 24 '12 at 13:07
    
I don't see "panel" under desktop->unity?! Using Ubuntu 12.10. –  Tomislav Nakic-Alfirevic Apr 5 at 16:56

As you can read on launchpad they changed the messages indicator and the pidgin indicator is not adapted to these changes. There is a ppa for the recent development but as it says on launchpad:

for quantal we will add those soon:
- pidgin
- xchat-indicator
- evolution-indicator

meaning we still have to wait for it :-(

If it's finally out you can add the ppa using

sudo add-apt-repository ppa:ubuntu-desktop/ppa
sudo apt-get update

There is no way to tell for sure what package you have to install after that but there is a good chance it will be

sudo apt-get install checkbox-unity
share|improve this answer

Under 13.10 the only solution to bring the sys-tray back is:

sudo add-apt-repository ppa:timekiller/unity-systrayfix
sudo apt-get update
sudo apt-get upgrade
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.