Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been using Ubuntu 11.04 for a few days. I installed face authentication login(I think it's 2.1 something) with the terminal. It was working well, but now what happened a few times later is it scanned my face, passed and says 'Face verify authentication has started', for half an hour without moving. I just can't get in. Please reply, I'm really in trouble. I have to solve this problem before my school opens.

share|improve this question

closed as off-topic by bain, chaskes, Sneetsher, Mahesh, Eric Carvalho Jul 10 at 11:35

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – bain, chaskes, Sneetsher, Mahesh, Eric Carvalho
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Can you tell us specifically which package you installed to provide the facial authentication? –  Christopher Kyle Horton Oct 16 '11 at 3:49
    
You should always be able to edit your own question when logged in. –  Takkat Oct 16 '11 at 8:50

1 Answer 1

If you are using the pam-face-authentication system (as described in this OMG! Ubuntu article), you can disable it by going to the text mode terminal and editing a couple configuration files:

  1. Press Alt+Ctrl+F1 to switch to the text console
  2. Log in using your username and password
  3. Edit the files /etc/pam.d/gdm and /etc/pam.d/gnome-screensaver and delete the whole line (there should be only 1 per file) that contains the string pam-face-authentication.so.
  4. Now enter the command sudo restart gdm to re-start the graphics session; you should now be able to log in using only username+password.

To edit a file, you can use this command:

sudo nano "/path/to/file"

e.g.:

sudo nano /etc/pam.d/gdm
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.