Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I like to use pidgin instead of Empathy because I'm used to it, and because I have to venture into windows for more development than I would prefer.

In Ubuntu 11.10, I can't find any way to get to the buddy list. It opens, and just sits there in the messenger panel tray thing. From its previous behavior, I believe Pidgin usually starts up minimized-- you have to click on its system tray to show the buddy list. The messenger applet does not seem to support this functionality. Is this a bug, or am I just missing something obvious?

share|improve this question

9 Answers 9

up vote 10 down vote accepted

Faced the same problem. Completely reinstalling (purge and reinstall) pidgin and it's dependencies solved it for me. Try the following in a terminal.

Purge pidgin and its dependencies:

$ sudo apt-get purge pidgin pidgin-libnotify pidgin-data indicator-status-provider-pidgin

Clear stale archives:

$ sudo apt-get clean

Reboot.

Reinstall pidgin alongwith dependencies:

$ sudo apt-get install pidgin

This solved the issue for me. Pidgin now shows buddy list from indicator menu and when I launch Pidgin manually.

share|improve this answer
    
That solved it for me as well. Must have been an upgrade issue. Thanks! –  Nicholas Flynt Oct 25 '11 at 16:08
    
Perfect solution ! By the way Pidgin/Ubuntu recreate the whole buddy list automatically, so you will not loose anything (at least in my case ;) ) –  Panique Aug 30 '12 at 13:37

Check the value of the list_visible parameter in .purple/prefs.xml, if it is 0, close pidgin, edit and change it to 1, then restart pidgin.

<pref name='list_visible' type='bool' value='1'/>

You can also try the same with 'blist_autohide'

<pref name='blist_autohide' type='bool' value='1'/>
share|improve this answer

Just wanted to mention I tried all of the above and nothing seemed to work. Then when I went in to Tools -> Preferences and unchecked the Status "Use status from last exit at startup" and changed the "Status to apply at startup:" to "Available", things seem to work fine. I am unsure why this seemed to fix it, but so far I have restarted a couple times and it seems to be working now.

share|improve this answer
    
Very helpful, not having to reinstall (and redo setup) saved me a half hour easily. (upvote this one!) –  Eric Wilson Jan 4 '12 at 15:02

This issue still occurs on 12.04. Sometimes, the only way to get it to work is to killall pidgin and use the launcher from the dash. However, I came up with a solution that works every time.

Use the following command:

gksu gedit /usr/share/applications/pidgin.desktop (or use your favorite editor instead of gedit)

Add this to the bottom of the file and save:

X-Ayatana-Desktop-Shortcuts=List
[List Shortcut Group]
Name=Display Buddy List
Exec=pidgin %U
TargetEnvironment=Unity

What this does is an an option to the pidgin launcher called "Display Buddy List" that always will show the list whenever selected. But, if the list is showing already, it will not open a second one.

So, long story short, if opening Pidgin from the messaging menu gives you that trouble, use the solution listed here. Even if it doesn't work by clicking the messaging menu option or using the launcher from the Dash, this will always work.

Note: To those wondering why I didn't advice to copy the Pidgin launcher to .local/share/applications, it is because the launcher in the messaging menu launches /usr/share/applications/pidgin.desktop. So, rather than editing the messaging menu, I advised to edit the original launcher.

share|improve this answer
    
This is a most excellent solution. –  Ether Jul 6 '12 at 17:43

Removing my ~/.purple folder solved this issue for me, I had copied my home folder from 11.04 over to 11.10.

Warning: deleting ~/.purple means you'll have to setup your accounts and preferences all over again.

Note: After doing this I now also sometimes need to load Pidgin with the -f flag for the buddy list to show.

share|improve this answer

Had the same issue. One thing that worked for me was going to the Unity "envelope" menu (where mail and IM notifications are shown) and hit "Clear". Then going back to the same menu, I selected "Pidgin Internet Messenger" and suddenly the buddy list appeared.

share|improve this answer

I also had this bug. One thing resolve the issue for me: setting "Show system tray icon" to "Always" in pidgins preferences. I don't know why or how, but now everything is OK.

share|improve this answer

I've got the same bug on my pc, can temporary fix it with disable and re-enable account in accounts menu entry.

added

just start pidgin with -f key, seems like bug causing by network-manager. in gnome 3!

share|improve this answer

None of the solutions worked for me, seems there are more people like me judging from this bug: https://bugs.launchpad.net/ubuntu/+source/pidgin/+bug/879960 (in case somebody comes across this)

share|improve this answer

protected by Community Feb 3 '12 at 13:15

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.