Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm on an ASUS K52F running Ubuntu 11.10 with the AR9285 wireless card. Wifi works acceptably before suspending, after it doesn't show any networks. the only solution I've found is a full reboot.

share|improve this question
up vote 14 down vote accepted

You can reload the wireless driver after suspend to avoid a reboot. My driver is 'ath9k' which you can find by running 'nm-tool' and look for the line similar to

Driver:   ath9k

Then to reload the driver:

sudo rmmod ath9k
sudo modprobe ath9k

To make this happen automatically when you come back from suspend we can add the following script at /etc/pm/sleep.d/00_wireless_sleep


case "$1" in
    /sbin/rmmod ath9k
    /sbin/rmmod ath9k
    /sbin/modprobe ath9k
exit 0

Replace the "ath9k" module name with the module you discovered from the nm-tool output mentioned above. I had to name the script "00_wireless_sleep" so it gets run after all the other resume scripts (scripts get run in reverse order on resume). Don't forget to make file "00_wireless_sleep" executable:

sudo chmod 755 /etc/pm/sleep.d/00_wireless_sleep

share|improve this answer
That worked perfectly! Thank you! – Archer13 Oct 18 '11 at 20:15
Adding options iwlwifi bt_coex_active=0 to /etc/modprobe.d/iwlwifi.conf worked for me. reference – Jared Beck Jul 29 '12 at 8:40
The issue is that if I suspend for too long I get these problems. Since none of the above answers work for me, here's what I do. Suspend again. Resume in 10s. Then it works. – MarkovCh1 Nov 11 '12 at 17:09
Note to future readers This answer still works(in 14.04) as of 11-25-2014. Thanks Ryan – TrailRider Nov 26 '14 at 2:25

I've the same problem, but with different laptop/wificard. Try to restart the network-manager service:

sudo service network-manager restart

share|improve this answer

protected by Community Dec 2 '11 at 19:10

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.