Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I updated my Ubuntu to 11.10 a few hours ago and the screen brightness keeps going up to the maximum and down to the minimum all the time on it's own. Sometimes it stops for a few minutes. And when I try to set it myself manually or when a few minutes has passed, it starts up again. (I'm new in trying to fix my own problems, so I might not get the obvious things right away.)

I now restarted a couple of times and now I'm using a newer version of kernel and the brightness is now constantly down and can't be set manually.

My laptop is a Samsung N220. I bought it a little over a year ago. I still have Windows 7 Starter on it (it was originally on it), but I had Ubuntu put on it from the start.

share|improve this question
1  
Welcome to Ask Ubuntu! We need more hardware information to help you, can you look at this question and then edit your question adding the information. –  Jorge Castro Oct 16 '11 at 2:38
add comment

5 Answers 5

sudo add-apt-repository ppa:voria/ppa
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install samsung-backlight

please note that in 13.04 that last command has changed to

sudo apt-get install samsung-tools
share|improve this answer
add comment

The solution in this thread worked for me

http://forum.ubuntuusers.de/topic/bildschirmhelligkeit-bei-gnome-3-spinnt-rum/

share|improve this answer
    
I had my friend take a look at my computer and he fixed it. I don't exactly know what he did. –  Agnes Oct 16 '11 at 17:04
1  
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Imagine the linked site goes down for maintenance or forever - your answer would become worthless. –  htorque Oct 17 '11 at 12:44
add comment

Solution can be found at Linux on my Samsung. I use this on my N210 and it has fixed a back-light issue I was having. They also provide the 'Easy slow down manager' which gets the other hot keys to work.

share|improve this answer
1  
Can you add some detail here? Did you just add the ppa and upgrade, etc.? –  Jorge Castro Oct 18 '11 at 13:55
add comment

The backlight flickering is caused by bug 810093 and affect many, if not all, Samsung netbooks running Oneiric. There are few workarounds from which at least these two work:

A) Download and install 'samsung-laptop' package from Fortunato's Linux on my Samsung testing PPA. The fix isn't (at least it isn't mentioned in the changelog nor in the bug report) in the stable Linux on my Samsung PPA.

OR B) Disable the kernel module by adding:

blacklist samsung_laptop

to :

/etc/modprobe.d/blacklist.conf

and then reboot.

share|improve this answer
add comment

Try putting this into the file /etc/rc.local:

setpci -s 00:02.0 F4.B=00

To set the brightness to maximum all the time. I don't know if it works for you but that did the charm for me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.