Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded to Ubuntu 11.10 and wanted to set up .z4 files so that they would be opened by gargoyle-free (as an example) although gargoyle-free is not an option in the default application list that arises from the context menu. It used to be possible to manually enter a default application directly from the dialog, however the feature seems to have been replaced by a simplified (and unfortunately useless) "Find application online" button. Is there perhaps a new way to do this that doesn't involve messing with the command line?

Some applications (like clementine audio player) aren't listed in "Other Applications".

share|improve this question

4 Answers 4

Right click on the file you want to open, select Properties, go to tab Open with.

enter image description here

If the application you want to use to open a file is not listed on the program list select Other Applications and press the button Add.

share|improve this answer
    
the vital 'Add' button is helpfully disabled. does anyone know the secret to making it work? (I'm on 12.04) –  Anentropic Aug 8 '12 at 10:44
    
@Anentropic askubuntu.com/questions/67382/… –  Bruno Pereira Aug 8 '12 at 11:17
    
thanks that's a useful tip... though it doesn't explain why Add button is disabled and how to make it work? Linux is so tiring sometimes... –  Anentropic Aug 8 '12 at 11:39
    
What if the application you're looking for isn't listed under other applications? –  Cyle Jan 28 '13 at 17:17
1  
@Cyle Shouldn't be hard. –  Bruno Pereira Jan 28 '13 at 18:19

Starting in gnome3 only apps whose .desktops have a %letter on the Exec= line will be shown on the right click > Properties menu, they also obviously need an appropriate MimeType= line.

In the 2nd example given here, clementine, the current Exec= is "Exec=clementine"

To show in the r.click > Properties menu it would need to be this, though other letter possibilities would be f or F

Exec=clementine %U
share|improve this answer
    
thanks, the %U proved to be the missing thing that was preventing my .desktop file from being listed as an option –  Anentropic Aug 8 '12 at 10:49

The button to add a new program to that list was removed in GTK+ 3.0, which is used in Ubuntu 11.10.

The good news is that you can add programs to that list manually by adding a .desktop launcher in ~/.local/share/applications.

The bad news is that the "Create Launcher" dialog was part of GNOME 2.0, so you need to create a .desktop lanucher manually. You could copy one from /usr/share/applications, open it in Gedit (it's just a text file) and modify the Exec and Name lines (and any other lines if you want).

share|improve this answer

The actual recipe for doing this on 11.10 is hidden behind the answers of imgx64 and doug and one extra step.

  1. To create custom launchers and edit existing ones with GUI you need to install the Main Menu app by typing the following into the console: sudo apt-get install alacarte

  2. When creating or editing the existing launchers with this app, make sure that the Command text field contains the %U template variable for the path parameter, e.g. clementine %U as it was noted by doug.

After that you will see your application in the Other Applications list of the Open With dialogues.

share|improve this answer
    
you do not need to install alacarte to add an launcher to an application. –  Bruno Pereira Jan 25 '12 at 19:16

protected by Community Jul 17 '12 at 18:47

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.