Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install "VMware-Workstation-Full-7.1.2-301548.x86_64.bundle" on Ubuntu 10.10-64bit (2.6.35-22-generic). It seemed to work - but then there is the WMware Kernel Module Updater which fails with "Unable to build kernel module." The logfile doesn't help me. It just says "Failed to compile module vmmon!"

Is this a problem of wmware, ubuntu or me? What do I have to do now? And why is there no "apt-get install vmware-workstation"-way?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

The supported method would wait for the next VMWare Workstation release, which will likely support the newer 10.10 Ubuntu release.

If you don't feel like waiting that long, you can patch your installation, as described at: debuntu.org: WMware Workstation 7.1 on Ubuntu Maverick Meerkat 10.10

share|improve this answer
    
Thank you! Unfortunately it did not work. The patch described in your link is for wmware 7.1 261024. The version provided by vmware ist 7.1.2-301548. And there is no other version to download at vmware.com –  Sven Oct 13 '10 at 19:56
    
The page you provided made an update... The new patch is for the correct version and vmware installed as is should. –  Sven Oct 20 '10 at 18:38

Friend,

Use the command chmod + x VMware-Workstation-7.1.2-full-301548.x86_64.bundle then type the command

./VMware-Workstation-Full-7.1.2-301548.x86_64.bundle

If an error occurs.

aptitude update
reboot
share|improve this answer
    
Thank you! The problem is after the installation. It's about building kernel-modules. Your solutions is a command-line-workaround to the graphical version which worked just fine. PS: There is no space between the "+" and the "x". –  Sven Oct 16 '10 at 8:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.