Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I like how Unity looks but I have 2 problems:

  1. Unity 3D
    When I login with Unity 3D, my pc becomes slower, I got an AMD II X3 with 2GB of RAM, Nvidia Gforce 6150SE nForce 430/PCI/SSE2 integrated.
    When I try to open the dash, take a lot of time to open, most often takes up to 5 seconds and while its opening remains fuzzy and unreacted, even the apps or folders take the same time to open and the same reaction.

  2. Unity 2D When I login with Unity 2D my pc goes more faster, the only problem is that i cant configure Unity as I want, I try to configure the Unity plugin in CCSM.
    For eg: I changed "hide Launcher" to: Never. It does not save changes, even when I restart my computer.

I don't know if the problem is with Unity 3D or with my pc.

share|improve this question
    
Sorry is Nvidia Gforce 6150SE nForce 430/PCI/SSE2 –  Cesar Gomez Oct 15 '11 at 23:45
    
Your English is good, I think I understood what you were trying to say. –  fixedit Oct 15 '11 at 23:50
2  
I think this question should be updated for 12.10+ and checked to see if the answers still apply. –  Luis Oct 30 '12 at 5:00

5 Answers 5

up vote 15 down vote accepted

In CCSM, go into the options for Ubuntu Unity Plugin and in the tab Experimental, change option Dash Blur from "Active Blur" to "Static Blur" or "No Blur".

You can also go into option Composite and disable "Detect Refresh Rate" and increase option Refresh Rate to over 60.

To increase performance further, you have to have Nvidia's propietary drivers installed (make sure you are using the latest version). Go into NVIDIA X Server Settings and in Open GL Settings Change "Image Settings" to "High Performance".

Remember these options will only apply with *Unity 3D*

share|improve this answer
3  
Changing the Dash blush even to None had significant improvements on my machine. –  Emil Ivanov Oct 19 '11 at 10:39
    
Thanks, ive updated my answer. –  Evan Oct 19 '11 at 21:46
    
Thanks i follow all ur steps but as Emil Ivanov even dont had significant improvements on my machine too :( even i got one more problem u can see right here "picasaweb.google.com/107400471364555567604/…; as u can see the icons are incomplete, can u help me with this? –  Cesar Gomez Oct 23 '11 at 3:34
1  
try restart unity. Run command: "unity --replace" –  Evan Oct 24 '11 at 5:49

Try installing the nvidia-96 drivers. Unity 3d works fine for me after that.

Also, Compiz tweaks will help.

share|improve this answer
    
thanks but still same, can you write the steps that you use to install nvidia-96, you did using synaptic? –  Cesar Gomez Oct 23 '11 at 3:29
    
just used "additional drivers" –  martu Oct 29 '11 at 16:25

I had the same thing with ati-drivers is a problem because some drivers do not support the procedures "GLX_EXT_texture_from_bitmap" it is necessary to work AIGLX. if there is no AIGLX everything goes through XGL, including 3D and therefore slow.

share|improve this answer

You cannot ust CCSM to configure the Unity-2D since it is not using compiz to show Unity. You have to use dconf-editor or you can use this tool :

http://www.omgubuntu.co.uk/2011/04/ubuntu-unity-2d-tweaking-tool-lets-you-adjust-the-launcher-dash-enable-compositing/

Hope this helps.

Luis Da Costa

share|improve this answer
    
Tks for ur answer i will try and tell u –  Cesar Gomez Oct 16 '11 at 2:31
    
Tks again, i with try 2D-Unity-settings and works good, i can configure it in my 2D performance, now how can i configure desktop effects? its not posible in unity 2D, i'm trying with CCSM but nothing. –  Cesar Gomez Oct 16 '11 at 16:02
    
I don't think you can configure de desktop effect (but I can be wrong), since, like I said earlier Unity-2D do not use Compiz so when using Unity-2D CCSM is useless... you only have 2 solutions : 1 - The software that I show you in my post. 2 - The gconf/dconf settings (but I can't really help with that since I am not using Unity-2D ... sorry :S) –  aliasbody Oct 18 '11 at 10:43

Try using the CCSM (CompizConfig Settings Manager) to disable other plugins first.

Does that help?

share|improve this answer
    
Tks for ur answer. already try this method and doesnt work, i cant edit anything with CCSM –  Cesar Gomez Oct 16 '11 at 2:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.